Run Remote stuck at "Launching Application..." in Parallels


With most of the my VMs in Parallels (W7 & W8), Xojo goes through build and transmit process fine but sticks at “Launching Application…”. Has anyone come across this problem?



Check the version # of Remote Debugger and note that there’s a 64 bit version (if you are doing 64 bit builds) - what Xojo are you using?

Sometimes I’ve found that you can use a newer version of Remote Debugger with an older version of Xojo and it works great (sometimes not).

Thanks for the quick response Michael - I’m using 18r1.1 with it’s corresponding Remote. W7 is 32 bit and W8 is 64 and I’m using there 32 bit Remote is both cases (as the build is 32)

Try this: uncheck “Launch Executable after receiving”. Then, run again, and manually double-click the debug app after it’s been transferred. Does the app launch?

Also, I’ve seen Remote Debugger just get confused after a half-dozen runs - restarting the Remote Debugger exe fixes it.

Other things that can affect this:

  • Build Settings / Windows / Gear Icon / Security settings (should be User)
  • remote debugger / options / Download Location folder in a bad place
  • dropBox or other live sync utilities
  • antivirus

Install DebugView from Microsoft in the VM’s and run during a remote debug session. See if there are any messages hinting at trouble.

Thanks Michael and Bob - I’m trying Michael’s suggestion first (takes a bit of time to build even on my new iMac Pro :frowning: Then I’ll give yours a bash.

Thanks again for the help

Thanks Michael! I’m Launching :slight_smile:

You’re suggested tool didn’t shed any light, but good to have it, thanks. By the way, do you have any suggestions on how to find the cause to a dreaded “windows has stopped working “ error. In the past I step through until I find the offending line, but in the case it’s only happening to a few customers and I can’t reproduce it myself :frowning:

No good suggestions. I have a project with a client that they’ve installed in various locations with wildly varying degrees of end-user capabilities and I ended up creating a daily log file and I do some high level logging using CurrentMethod and if I think I need more detailed information I add more in the method I think might be causing issues. At least then I have some clue what’s going on and can make some educated guesses. The logging slows it down quite a bit but this app doesn’t need performance and I can always turn the logging off - though my guess it’ll just keep creating daily logs until it runs out of drive space (in 20 years).

To others who may find this thread. I just came across this issue on XOJO 2019 r1.1

In my instance I was attempting to remote debug a restful api on an OSX server where the session would start downloading and never run.

To resolve I un checked ‘Launch executable after receiving’
Then when ‘Launching application’ appeared I right clicked on the appropriate executable and set its default action to Terminal. Then every time after that the remote debug session worked properly.

It had been a while since I performed a remote debug and it is very possible an upgrade or a system reset occurred that wiped out the executable association

To others finding this thread… I tried a gazillion things and then… Restarted Xojo. Problem solved. :wink: