Run my app in Linux distro

Hello,
I was reading and not got anywhere :frowning:
Today I tried to run a simple window on the operating systems supported by the IDE.
The window was compiled in the IDE on Windows7. I was surprised to not be able to run my window on Linux.
What I need for run my applications to a Linux distro like ubuntu or Fedora?

Thanks,
Rui

Is this a 64-bit version of Linux? Xojo apps are 32-bit and require the appropriate 32-bit compatibility libraries to be installed.

hello Paul,
The test was performed on the last ubuntu 13.04 32bit,
Which librarias have to install?

Rui

If it is 32-bit Linux, you usually do not need to install additional libraries.

I just built a quick app on Ubuntu 13.04 running on VMware Fusion and it worked fine.

However, Ubuntu 13.04 may have issues with HTMLViewer (it needs libwebkit, libwebkitgtk, libgtkhtml which may not be installed by default). Apps that don’t use HTMLViewer should be fine.

Try running the app from the Terminal to see what error messages get output to the console.

When you compile for Linux, let’s say MyAppLinux, it creates a file called “MyAppLinux” and a folder called “MyAppLinux Libs”.

  1. Zip both and extract them into a folder on the linux machine.
  2. Maybe you will need to change the attribute of MyAppLinux to executable via terminal with: sudo chmod +x MyAppLinux

Is it ok?

Hello,
needed to install the libs libc6-i386 and ia32-libs
seems to work fine now \o/

Rui

Well… Seems that you had a 64 bit edition , not 32. :wink: