Run Mac, not Window

My web application works well on Mac but displays this message on Window.
I only use a WebImage, WebHtml, WebLabel and WebText.

Could not execute returned javascript: textlabel is not defined
Source: var langdir = document.getElementsByTagName(‘body’)[0]; if(langdir) { langdir.removeAttribute(‘dir’); }
var langdir = document.getElementsByTagName(‘body’)[0]; if(langdir) { langdir.setAttribute(‘lang’,‘fr’); }
new imageview(‘MUWR69HY’,[]);
Xojo.controls[‘MUWR69HY’].setEnabled(true);
Xojo.input.install(Xojo.controls[‘MUWR69HY’].object());
new textlabel(‘DlGAU9QP’,[‘TextChanged’]);
Xojo.controls[‘DlGAU9QP’].setEnabled(true);
new textcontrol(‘M3FEcKr8’,[]);
Xojo.controls[‘M3FEcKr8’].setEnabled(true);
new frameworkObject(‘Tdxj6Gt9’,[]);
Xojo.controls[‘Tdxj6Gt9’].setEnabled(true);
new frameworkObject(‘WHzwkoCz’,[]);
Xojo.controls[‘WHzwkoCz’].setEnabled(true);
Xojo.view.showPage(‘WHzwkoCz’);
document.title = “123 Univers”;

Xojo.view.dismissLoader();

My application is installed on a Server MiniMac Maverick.
What could it be?

Alain Lortie

You say Windows but what browser? and what version? It matters more than the OS for WE.

Basically, the server is trying to manipulate controls on the client that aren’t there yet.

  1. Make sure you don’t have any code that manipulates controls in your Open event.

  2. See if your app works on 2013r3.2, but not on 2013r3.3. If that is the case, there is an upcoming fix that will probably fix your issue.

All browsers.

3.3

So I’ll wait. And do the tests on the Mac.

Thank you for your attention.

Go back and build with 3.2. See if that “solves” your problem. Then you will know whether a particular upcoming fix might solve your problem.

Xojo 2013r1
Released: June 4th, 2013

This is the last archived that I could find into the XoJo site.

Do you have a better connection, or I can do a test with this version? Be assured that the code is good. It worked very well for 6 months.

Alain

I have news.

www.domain.com and domaine.com, does not work well.

index.domain.com works.

I do not know if it comes from the server or XoJo.

Merci de votre attention
Alain

Sorry. Test a build made with Xojo 2013r3.2. Let us know how that works.

I would like to test but I’m not able to find XoJo 2013r3.2

Alain,
I’ve you gone through stakoverflow similar situations:
I googled relation between JS and label no defined - and got that:
https://www.google.com/search?client=ubuntu&channel=fs&q=javascript+textlabel+is+not+defined&ie=utf-8&oe=utf-8
some cases were solved there.
…what wouldn’t we learn without windows ?
:slight_smile:

I assumed that old Xojo versions were here:

https://xojo.com/download/archives.php

But they are not. Drop a letter to support and ask for them. Do you have any older than 2013r3.2 versions on your computer? The point here is to see if a particular fix made in 2013r3.2 broke your app. It’s happened to several people, and a fix is “coming soon”.

<https://xojo.com/issue/31056>

I do not see better then

Xojo 2013r1
Released: June 4th, 2013
Xojo2013r1.dmg

If this version can do, I can do tests!

But if the fix is coming soon, I can continue to program anyway.

I’d like you to be able to verify that this particular fix might solve your problem. At any rate, 2013r1 might do. Does your project run OK when built with that version, but fail as you describe when built with 2013r3.3? If that’s the case, the an upcoming version might fix your problem.

Both versions, r1 and r3.3

Mac and Window…

Everything worked well for more than six months.

I’ll wait for the fix.

The 4.1 version has solved the problem of java script on Windows. This version works well on mac miniserver Maverick.

Alain, I’ve seen a few projects that triggered this particular bug. One suggestion I’ve given other developers is to adjust their programming style so that they are not directly getting/setting properties of one WebPage from another, especially if they’re relying on implicit instances of WebPages to make it all work. That is what triggered this problem for you.

Fix for Explorer, Firefox on Window

Not fix for Google on Window.

I do not know if it depends on the programming.

Xojo 2014r1 WE project exhibits this issue - works on Mac during testing, fails once deployed to linux host.

Caused by a WebTextField, type=Number, open event sets me.visible=debugbuild

I would report it as a bug, but feedback update fails to install…

Download the program from Xojo servers (by hand) and install it from there.

Hi Alain, sorry, can’t help, just wanted to point out that it is Windows (with an S at the end) if you mean the operating system.