Run grayed out in new Linux install

I just installed Linux Mint and Xojo 2020r1.2 on an old computer. The Run button for the debugger is grayed out, but the Build button works. I downloaded the Debian version of Xojo and double clicked it to install. I copied my project binary file and set its permissions to read/write. Is there something else I need to do?

hover over the run button and it should show a tooltip with information

The tooltip simply says “Runs your project using the debugger.” Not much help. I am wondering if part of Xojo did not get installed.

Aha, i’d expect it to tell you why it’s greyed out.
Probably a missing library? Do you have “libunwind8” installed?

The Run button can be disabled if there is an active debugger but the IDE hasn’t talked to the app yet.

I have used the IDE to make changes and saved them. The Run button remains grayed out. libunwind8 is installed.

I reinstalled Xojo then loaded one of the examples. The Run button was enabled. I loaded the project I developed on Windows and transferred to the Linux machine and the Run button is disabled.

Is “This Computer” checked?

1 Like

Found the problem. Under the Build Settings, Architecture was set to ARM 32-bit instead if x86 64-bit. I had built it for an rPi, but couldn’t get Remote Debugger to work. Didn’t think about the architecture. Thanks for your help.

1 Like