Run button not available for iOS project

I installed Xcode, ran it and accepted the license agreement and then ran the iOs simulator. I even made your basic hello world app in Xcode for iOs and it ran fine.

When I create an iOS app in Xojo the Run button is not available.

I know I missed something and I checked the “getting started with iOS” in the docs…

Can someone tell me what I missed?

link text

Disclosing the mac OS, XCode and Xojo versions ?

OSX 10.14.3
Xojo 2018 R 4
Xcode 10.1


The only other thing I can think of is that in some cases you may also need to go to the Xcode Preferences, select the Locations tab and choose “Xcode 10.x” for the Command Line Tools setting.

Do you have a simulator selected in Build Settings > iOS?

This could be particularly important if you have more than one version of Xcode installed.

Yes, @Paul Lefebvre; that was it. Thank you very much.

For some reason the location of the command line tools was not populated in Xcode. I selected the tools, entered my sudo password and that solved the problem.