Run a program after build (windows)

Are you running on the physical hardware on the only login or are you connecting via remote desktop or some other remote system?

physical hardware

Any anti-virus software that you could quickly disable to test?

no antivirus

Could you try this. Close down Xojo, hit the windows button, find it in the list, right click it, More, Run as administrator then try the file I posted earlier? Any difference?

Could you try and run the program as an administrator. I have run into this occasionally with shell commands.

It’s just a guess.

nothing, all like before

I’ve gone through all the things I can think of, best make a ticket about it in feedback as its working fine for me :frowning:

Thank you, I opened the ticket in feedback.


If only Cristiano has the problem and others don’t, how can Xojo know how to fix it?

Can you help Xojo help you? Some things like:

  • if you have other windows machine with same Windows 10 release, does it work or same problem?
  • can you test on other Windows version/release?
  • are you using Windows in English or other language?
  • do you have all the Windows updates or you blocked some?

I don’t know what else you can do to find the problem or help Xojo to reproduce it so they can fix it.

DoShellCommand is Synchronous. It must be if you want to be able to get a response string back.

Instead of just calling the program directly, how about prefixing the app name with start /b

That was tried already, no change.

Last update:

I tried reinstalling xojo but nothing.

I changed windows machine with same Windows 10 release, and surprise: it works!
Conclusion: The culprit is my windows 10, same version of the other machine.
Computer mysteries!
The problem is that the I have no error messages, but xojo stops responding.
In any case, thank you all.