Router Login HTML Viewer.

I know this is a little vague but I was wondering if anyone knows why this happening. I have an HTMLViewer and I am trying to access a router login on my LAN from within the HTMViewer using LoadURL. Using any version of Xojo or RS after 2011 r2 I am not greeted with the login popup window. Can anyone explain to me why and how I can get this working on newer versions of RS or Xojo? Thanks!

Try setting the UserAgent property. It is possible the router does not want unknown browsers to connect.

Thanks for the reply, I did try that earlier before I realized that property is OSX only. I am currently working with WIndows.

It works on Windows as well. See where Norman Palardy tested it.

Ok thanks I’ll definitely give it another try.

I tried a number of user agent strings and I still can’t get the router login popup in the htmlViewer. I also tried changing the Renderer to Webkit(1). Still goes straight to the 401 page. 2011 r2 opens it fine, I don’t get it.

Are you using the correct port? Usually router admin pages runs on port 8080.

I’m trying to login to the admin GUI in the router which is on port 80. As I said earlier I can get to the login popup using 2011 r2 HTMLViewer control. I noticed that the HTMLviewer that works doesn’t have the option for native or webkit. 2012 r2 and Xojo just send me right to the 401 page, as if I pressed cancel on the login popup or entered bad credentials.

The router is running a linux based OS and the GUI is Interactive Ajax based using SVG and CSS-based color schemes.

Is there a plug in I need or something to get this working? Thanks…