Remote Debugger No Longer Works

I’m losing my mind here.

My primary development machine is an M1 MacBook Pro running 12.3.1.

I’m using Xojo 2022 r1.1 (but the problem I think started with 2022 r1).

I used to have the Xojo Remote Debugger running on a Windows 11 laptop on the same local network as my Mac. It always worked perfectly.

A couple of weeks ago, the remote debugger just stopped working. As far as I can tell, nothing changed on either the laptop, my Mac or the network.

I have rebooted both systems multiple times. I am running the Windows Remote Debugger as administrator (as usual). The Mac IDE just simply does not find the remote debugger. If I try to “auto discover” the remote debugger it doesn’t show up. If I enter the IP manually it just hangs when building and never connects (fails to connect to the debugger). I have manually force opened the TCP and UDP ports on Windows (44553) but this hasn’t worked.

Does anyone have any idea how to solve this? I really am at my wits end and can’t think of anything else other than nuking the Windows laptop and reinstalling it which seems absolutely ridiculous.

It’s worth mentioning that I can connect perfectly fine using a Windows 11 VM in Parallels on my Mac.

Does a portscan show open ports? Any firewall software involved?

How about uninstall the Remote Debugger App on your Windows Laptop and install it again and/or remove the Remote Protocol and add it again to the Xojo Settings?

Tried both of those options but no luck.

I’m starting to wonder if it is an issue with the console remote debugger (which I had never used before).

I launched the console version of the remote debugger (the GUI version was quit at this point). Since that moment, neither the GUI version or the console version of the debugger can be seen by the IDE on the Mac.

I relaunched Parallels and checked that the GUI remote debugger worked (it did). I then quit the GUI debugger and launched the console debugger - this has caused both to stop working. Restarting Windows has no effect.

Something is really borked here.


First of all, at the risk of stating the obvious, make sure your Windows build setting in the IDE is 64-bit.

But I’ve had something similar, albeit in my case I was remote-debugging to VMs on my dev machine. In Fusion, I had the network adapter set to “autodetect” instead of “share with my Mac”. This would ostensibly give the VMs a DHCP address, but I found it helped to actually assign them static IPs.

I also recall that, once I’d set up a remote debug target (by typing–autodiscover was of little use), it would hang as you say unless I quit and restarted Xojo.

You’re debugging a console target, though. That’s an unknown world for me.

-Does it work with a previous Xojo version?
-Check the list of ports on the windows machine, are they open, connected…
-Disable the firewall?

Also, make sure you’re using the latest version of the remote debugger stub. If anything major changed, it wouldn’t necessarily be backward compatible.

Might be a network problem. The computer running the remote debug is essentially a server. I’m assuming you’re on wireless … some routers enable “wireless client isolation.” This means that wireless devices cannot talk to each other. You want this in a public place to keep your device safe. But it prevents your server (remote debugger) from receiving any connections.

Check the settings in your wireless access point or router.

A long shot but worth a try. We’ve recently had a rash of clients with connectivity failures after Windows update reset the network profile from Private to Public. All starts working again after the flicking back to Private.

Just wondering if the people blaming the network have seen Garry’s post about a reproducible procedure to cause this failure?

I want to confirm his findings but I’m terrified to intentionally break remote debugging with no known fix. If what Garry has found is the true problem then Xojo needs to step up.

I volunteer someone else to test Garry’s findings :wink:


Thanks @Tim_Parnell .

After trying all of these suggestions I decided to nuke the Windows PC and reformat. Low and behold - it works again. Not helpful for most but at least I can debug again.

For what it’s worth (since I did not know this) - you don’t need the Remote Debugger Console version to debug console apps - the Desktop version seems to work too.

1 Like

You haven’t mentioned whether you could ping each computer, though. Was the remote debugger the only app to fail, or you had one entire computer not reachable?
I recognise it’s too late to tell, as you’ve already reinstalled the Windows computer; just pointing out you didn’t mentioned this information.

The debugger was the only app that failed. I could definitely ping the Windows laptop and access its public folder from my Mac.

1 Like

Thanks for confirming.

I feel like I experienced this once a few years back on one of my VMs, and got some help from one of the Engineers. I couldn’t remember the solution or find the conversation, though. I’m glad you have it sorted out, even if you did have to take the nuclear option.

1 Like

Mainly the Remote Debugger Console is for servers that are running headless or you only have shell access to.

1 Like