Remote debugger fails over a vpn

Hi all!
I have a problem: I’ve sent to a customer the RemoteDebugger Stub, I invited him to connect to my VPN to make a remote debug. We both disabled all firewalls.
My Xojo can send the application to the remote debugger, but there, when the app starts, appears “Cant connect to the debugger” message.
I’ve tried this many times in the past, with the same vpn settings, and it worked fine! Can be a problem caused by Yosemite (present on my Mac and on my customer’s one)?

Thanks a lot!

I use a VPN with Yosemite for remote debugging and it works just fine, but I’m also the VPN client in my scenario. I will say this though… Yosemite did change the way the built-in VPN works. I had to reconfigure my network to get it working again after upgrading because my router was no longer compatible.

Your customer may need to set “send all data over the VPN connection” though. The remote debugger requires that it be able to create a returning connection to the IDE.

“send all data over the VPN connection” is already flagged :frowning:
Thanks for the suggestion…