Dear all,

i could not get my remote-debug to run.
Version: Xojo 2018.3
Connection: VPN
Local: MAC
Remote-Machine: Windows 10 Pro, 64-bit

  1. I connect the Debugger over the IP
  2. Click “Run Remotely” on my Xojo-IDE
  3. Xojo says “Transmitting File To …” (it seems to transmit)
  4. Xojo says “Launching…”
  5. Error-Message On the Remote-Machine: “Since we could not locate the target IDE to start a debug session, this application will now exit”

What may be?

Best Regards,

Desktop or console app?

32-bit or 64-bit app?

Latest version of Remote Debugger running on the Windows box?

Firewall issue? Anti-virus issue?

Remote Debugger configuration is described here:

It sounds like you might not have the proper ports open on the two machines.

Hi Kem and Paul,

a) i updated Xojo from 2018.3 to 2018.4 and moved the included Remote-Debugger to the Remote-Machine (WIN, 64-bit)
b) opening ports, regarding to Xojo-UserGuide => no success
c) switched off Firewall completely on both sides => same result: Remote-Debugger receipts the app and then it says “can not locate target IDE”.

is there a possibility to check on which point / port it hangs?

A Diagnostic-tool for the remote debugger would be fine…

As i startet the Remote-Debugger first time, windows asked me to allow connections for this app, and i see it in the firewall of the remote machine: Rules for “Remote Debugger” are added.

… How can i see if a Anti-Virus is blocking my Remote-Debugger?

You mentioned in your first post that a VPN is in use? Could that be confusing things?

If you hold Shift when launching the Remote Debugger Stub, it creates a “Stub Log” file on the desktop that contains log information that can help you troubleshoot any Remote Debugger configuration issues.

i holded down Shift while launching “Remote Debugger Desktop.exe” and it created a empty File “Stub Log…” on the Desktop.

has anyone experience with remote-debugging over VPN?

I’ve actually done that from macOS to Windows 7. It’s been a while but as long as you’re getting a remote IP on your computer, this should all work.

One thing you could try is to go to the remote debugger preferences in the IDE and set the interface to the VPN. Oh, and make sure the debugger stub is also using the right interface.