Remote Debug Fails with "Could not Launch Because Can't Create File"

I’m unable to remote debug a project—it keeps saying “Could not launch because Can’t create file”. The file in question is in a folder that should be copying in via a copy Build Step. This works to build and debug locally.

Has anybody else run into this sort of problem?

Version info:
I’m building on Mac OS X 10.11, Xojo 2016 r3 to try to run on Windows 10 with the 2.0.4 Debugger Stub (which is bundled with 2016r3).

Check permissions of the target folder.


I think I finally found the problem. Rather, there were a couple of problems.

1.) As Greg said, the permissions on the target folder weren’t right in a way that didn’t make sense, especially because I tried running the stub as Administrator which I thought would resolve any permissions issue. No such luck. Went back to default target temp folder.

2.) Found that one of the many files I was trying to copy into the project (a png file) had “extended attributes” in the Mac Filesystem for some reason. Once I removed that one file, the process worked. Well, after I fixed problem #1.

I think the only part of this that might be a bug in Xojo is in dealing with files that have extended attributes.

Thanks for the fix-ideas!

One problem with that is that the IDE cannot know if the extended attribute is what you intended.

What I should have said is that maybe Xojo is failing to include the file in the debug tar package because of the attributes. It seems to such attributes should just get stripped out in going over to Windows, as they don’t translate cross-platform.

I don’t know what happens if you try to copy in extended attributed files when doing a remote debug from Mac to Mac, where could actually work.

Argh, this just bit me again.

I have made a relatively general fix for this in the form of a build script for my Windows builds:

[code] // Remove extended attributes from resource files, because they stop debug (and possibly other things) from working

Dim ResourcesPath As String = CurrentBuildLocation + “/” + CurrentBuildAppName.ReplaceAll(" “, “\ “).ReplaceAll(”.exe”, “”) +”\ Resources"

call DoShellCommand("xattr -c " + ResourcesPath + “/*” )

call DoShellCommand("xattr -c " + ResourcesPath + “/menuIcons/*” )

call DoShellCommand("xattr -c " + ResourcesPath + “/SimFiles/*” )[/code]