Recover binary Xojo file with out of bounds exception crash

I inadvertently but an invalid number, (too large) in a Window with in a project and it caused an out of bounds exception crash. In an effort not to lose my work when it crashed it allowed me to save so I did. Now It crashes when I try to reopen the file. This is a binary file and not XML so I have no way to change that bad window width value and I get an out of bounds exception every time I open it. I hate to lose all the work on this project. Any suggestions for editing a window width value in a Xojo binary project?

Have you tried Arbed?
It’s able to read binary file projects

Drat! I was hoping Arbed would do the trick but it gives me the following error:

There were Errors Loading
Unknown block item type ($44626C20) (in class RBPrjBinaryFileReader)
(file: ReplayitPixFizzOrdersWebD1.xojo_binary_project)

Arbed hasn’t kept up with additional items added to projects or even some new data types being written
I’ve not seen Thomas around in ages

I’ve just started recreating the project. It wasn’t so far along that I will waste less time starting over than trying to fix the corrupt one. I will say I think it’s a bug that the IDE allows an invalid number to be entered into an object’s width and then creashes if you do. It should not allow anything outside the minimum and maximum values.

If you do not use version control, you should at least regularly save the current version at the end of your work, so when stuff hit the fan, you can at least go back to what you did the day before.

A simple way is to have a backup folder where you copy your project file, and append the date to the name.

Quite a while ago I had a project go strange all the sudden, and it would not load anymore. I did not have a backup. That taught me…

I do save regularly and often and as versions as milestones are reached, and or versions daily. This one was started this morning so only one version s far. I just hated that I had to start from scratch again for something so silly as fat fingering a window or listbox width and wasting my entire morning.

Hello everyone

I have been working in a proyect over a month. Suddenly today XOJO CRASHED. v2016r4

I regurlarly ctrl-save as a compulsive action inhereted from my visualbasic 5 times. Prior to every RUN, and after every new two to ten lines of new code. In fact, the crashed ocurred inmediatly after the last ctrl-save .

When lauching XOJO again NO RECUP dialog pop. Checking the folder, the project went down to 1K size (out of 4000K ). Searching manually for a backup file, no one was found. Is there a folder or extension file to search for?

As an precautionary measure, I save as the project as v2, and keep on working in this v2 from september 13 up to today.

My viewpoint is that there is a TIMER BUG. During two months i have been working in the webapp, not even once crash happened. Today I begin adding some timer controls in order to check for a file change and for displaying a message for with a small duration. When done with this, the crash happened.

My only hope is to understand where the backup is saved by XOJO. Any info?


If you havent been creating backs up or using version control then you may be sunk and have to go back to a new copy of the version from Sept 13

Thanks Norman

it sucks but I dont know of any other way especially if it didnt offer to recover unsaved changes when you started the IDE again

your are right
it did not
well, the good thing is that i have clearer the modules, proceses and else, so I expect to be updated in about a week
thanks Norman


  1. use the Xojo project text format and some kind of version control system (svn, git, mercurial, cvs - something …)
  2. save often
    1. and 5) see recommendation #1

Just a thought, but have you tried restoring using “Previous Versions” on the source directory?