Real Studio goes Spanish on 10.10. Why?

After installing OSX 10.10, some older versions of RealStudio decided to speak Spanish. Really annoying. How can I get back to English? Yes, I do need access to the older versions for a number of reasons!

When Norman Palardy comes around, am sure he will be able to help.

In the meantime, within the RB2012 bundle Resources folder is a folder called es.lproj that looks terribly much like the Spanish support. Maybe removing it from a duplicate of the app could fix it ? Don’t do it on the original in case it breaks something. I could not reproduce the issue, so I could not test.

It’s on my home machine, so I will try it tonight. I always try new system updated on my least important computer in case something goes wrong, which it did in this case. It stayed English on some versions but not all. I have always used the English version, and the only Spanish used is an occasional compile of a Spanish version of my program.

There is an old app called LangSwitch that can be used to switch the language of an app. It’s available here:

Which versions are you seeing this?


Thanks. I’ll take a look today.

I got 2011r4.3 on my machine under Yosemite final version, no Spanish.

It may depend on whether you installed the localized or English-only version of the IDE.

Oh… Of course : my version does not have anything besides en.lproj :wink:

More in detail:

Haven’t tried 2007-5 as it wanted an older Java
2009-5 Not working
2011_4.3 Not working
2012_-1.1 Working

Have never used anything but the English version

LangSwitch worked . Thanks!