Project Path affects Xojo behavior

Hi folks, on MacOS I’m experiencing a really strange behavior of Xojo 2020 r2. In fact the Desktop App Debug makes the app crashing if I run the project from Documents, all fine if I run the same project from the Desktop, all of that randomly. I’m not an expert of Xojo but I’m pretty sure this is far abnormal. Is there someone that experienced the same bizzare behavior of mine? Is there a solution to that?

Crash report? Which version of Xojo? Which version of macOS? Do you synch to iCloud? Which is a really terrible idea to do.

1 Like

No one, white window and nothing more. Xojo 2020r2, High Sierra. No. It’s just App Anarchy, to be frank pretty unbelievable cause it seems to happen totally randomly! LOL

Hm… that’s hard to diagnose then. Have you rebooted?

The reboot change nothing, I had the same issue yesterday. I read many others complaining about Memory Leak, I even don’t know what it truly is but the loading spin of mac run endless till I stop the debug so I think could be that thing I even don’t know.

What says Disk Utils ?

Did you trashed the Xojo Cache folder(s) ?

Under RAM constraints, everything can happens.
If you run too many applications, the system may clears some features (the Recent items Menutem, Burn a Disk [CD-DVD], etc.; some other things, not obvious / not visible may become unavailable)

Did you boot with Cmd-Alt-P-R pressed and wait until 5 beeps ?

Thank you Emile, I cleared both, cache and preferences and nothing changed. I have problem with nothing but Xojo so I think the problem is going to be Xojo, I wouldn’t look at MacOS, not at first at least. Do you agree? 16 gb Ram i5. Do you think that 5 apps can make this to happen? I don’t.

Could be the fact that I use to run the same project from two different paths? I usually work the temporary project till I need to overwrite the official project but this method creates no problem with no other app, I always do that.

When Xojo goes white again do a capture of Xojo in Activity Viewer.

You might wanna have your projects inside a (subfolder of) you user folder if you have iCloud sync on your Documents and Desktop folders can get issues with your project files.

I always use folders nesting but never iCloud. Anyway I’m pretty sure now that the first time I open the project after the cache is cleared the problem never occurs but to be sure I should go for a deeper test comparison. Desktop Vs OtherFolders.

Of course, until you start having troubls.

Doh, you are haing troubles ;-:slight_smile: (but this. may not be related).

When every possible reasons failed, time to consider the impossible.

Just do a simple test.

Potentially several issues I can think of.

  1. DropBox, iCloud, Google Drive, Microsoft Drive, any of those set to “share” your documents folder can cause apps to get screwed up when being built.
  2. There could be a permissions problem with the Documents folder (in fact many), that can screw up all kinds of things. Download Permissions Reset, but DO NOT reset the permissions just yet, but add your Documents folder, then select Get Info from the “File” menu and copy/paste the result into this forum.
  3. Is your disk APFS (Use Disk Utility to check) or HFS+?
  4. If you were running macOS 11 Big Sur, I would say that I’ve seen apps sometimes have problems from any other folder than Applications. Also with Big Sur, Apple have added a new Permissions Model (that is set by the OS and non-user modifiable), which is causing problems with certain Home folders.
  5. If you build the application on the Desktop, then drag it to the Documents folder, does it work there?
  6. If you create another user on your Mac (incase it’s a user account error), will the application run from that user’s Documents folder?

Hope something helps.


After cleared the Project Cache I only opened the project from the same Path. The issue persists.

I must rectify myself => To clear the Project Cache does not fix the issue.

Very Interesting Sam, thank you very much!

  1. I use no shared folder or Could Apps in my WS.

  2. Unfortunately it does not solve my issue.

I’m using High Sierra so…

  1. No

  2. No

  3. Got a try but the Project debug crahed even while on Desktop.

  4. I’d prefer to not try it.

Interesting thing I just experienced. I don’t know if it’s relevant or not (it shouldn’t be)

  1. I run the debug with the “Container2” Selected. It crashed.

  2. I run the debug with te “Window1” Selected. It worked.


High Sierra was the first macOS to support APFS, I don’t know if Apple auto-converted your drive or not (I never actually used that version of the OS), after seeing all the fighting people had with external displays.

It is not difficult, and you can delete the user once you’re done.

Any chance this is “App Translocation?” I ran into this recently.

Do you know what is causing the crash (that is, where in the program it crashes and what it is trying to do at that point?) May give you a clue if it is related to this.

Translocation should only be occurring if you’re running software downloaded from the internet.

That’s a very odd duck which you should make feedback case for.