Problem with WebApp (NilObjectException)


I’ve got a webapp, which runs perfectly on my mac.

Now I uploaded to my Server, and there occurs an “NilObjectException”.

I’ve placed the “ShownEvent” in a timer.action-event for testing, because the shown-event did not work.

But all I do, the same result. On my Mac is all fine, on the server not.

Can someone look into the Exeption-Description?

Here’s the Link:

What’s in the Timer.Action event?

a DB-Query from my SQLite DB.

The DB is connected (otherwise there would occur a msgbox)

And with the results of the query I embed some ContainerControls. Here’s the code:

[code] dim str as string = “SELECT * FROM Geschenke;”
dim rs as RecordSet = session.DB.SQLSelect(str) 'the query
dim akt as integer = 1
app.DefaultPage.Title = (cstr(rs.RecordCount))

if rs <> nil then
while not rs.EOF
Dim D as new WL_Item
D.Title.Text = rs.IdxField(2).StringValue
D.Desc.Text = rs.IdxField(3).StringValue
D.ID = rs.IdxField(1).StringValue

  d.Style = Cont
  if rs.IdxField(4).StringValue.Len > 0 then
    D.Button1.Style = Button_belegt
    d.Button1.Caption = "bereits beansprucht ;)"
    d.Enabled = false
  end if
  dim w as integer = d.Width
  if w < self.Width then w = self.Width - 10
  dim l as Integer = (self.Width / 2) - (d.Width / 2)
  dim t as integer = akt * (d.Height + 10)
  d.EmbedWithin(self.Trger1, l, t, d.Width, d.Height)
  akt = akt + 1

end if[/code]

hmm, if I manually select the data from the DB (over the SQL-console behind the button), then it returns an empty result. But in the DB ARE results!

I would think that RS is probably nil.

no, then it would happen nothing, because of the if rs <> nil then


hmm, as it works in debug on your mac. Could it be a permission issue on the db file?


I’ve re-written the DB and now it works…

The DB on my Mac is fine, if I upload it to the server it is broken.

so, ok, that’s the solution…