Problem with installing WebApp on Webserver

*send any data to browser

now I tried the port-option “select automatically” - same result, only on port 53972

You should use a port above 10000.

You said you had both shared and VPS servers, but didn’t specify which one you are using for this app. It needs to be the VPS. Most shared servers either won’t allow a separate process (app) to run that listens on a port, or won’t allow it to spawn more than a couple of instances.

okay, I load it on the VPS server (the JiffyBox)

there is an other error (it’s crazy how complicated it is):

Here, it’s hosted

I gave the permissions “755” to the files.

644 is sufficient for config.cfg

Yes, as I said.

[quote=36367:@Lars Lehmann] Cannot write to config at path /var/www/collectboard/config.cfg. Permission denied

I gave the permissions “755” to the files.[/quote]
The cgi/app needs write access to this file. I usually use 664, though 775 will work also. It usually needs Group write as the cgi/app is run by the Apache user.

Also, I use Yummy FTP (on Mac OS X) to upload my files. A nice feature of this (don’t know about other ftp clients) is that once I set the permissions on the files on the server, I can upload/overwrite them and it keeps the permissions as set on the server. So therefore I don’t have to keep re-setting the permissions. It’s just one less thing to have to worry about.

yaaaaa!!! I got it!

I don’t know how, but it works!

I changed the port back to 8080, loaded it on my VPS, and set followed rights:

  • the config.cfg to 666
  • rest files (and directories) to 755


Thank you guys, for the very impressive help!

here’s the link

[quote=36372:@Lars Lehmann]yaaaaa!!! I got it!
Great! Now, there are some things to remember if you were to deploy more apps to the same server.
They will need different Application Identifiers and use different ports :slight_smile:

thanks! I think I would have it done wrong! :wink:

This threat is a good tutorial for other newbies^^