Problem WEBAPP with SSL (I can't do it work)

Hello all,

I have a problem creating a webapp with SSL certificate for testing and I don’t know where is my mistake.

I have created a cert in

I have downloaded the two files and I have created a new one with the content of both files.

I have saved it with the same name as the executable file and put in the same folder as the file.

I run the server with --secureport= …

But when i try to navigate to the webpage I get the message

SSL_ERROR_RX_RECORD_TOO_LONG

When I run my webApp, I use the switch to specify the certificate file:

--certificate=/path/to/my/WebApp.crt

Also, the .crt file has 3 parts:

  • Public Key
  • Intermediate Certificate
  • Private Key

perahps you are missing one of the parts?

The .crt file is just a text file, so you should be able to open it in a text editor as needed.

It should look like this, roughly:

-----BEGIN CERTIFICATE-----
  [... data for your public key ...]
-----END CERTIFICATE-----
-----BEGIN CERTIFICATE-----
  [... data for any intermediate certificates ...]
-----END CERTIFICATE-----
-----BEGIN RSA PRIVATE KEY-----
  [... data for your private key ...]
-----END RSA PRIVATE KEY-----

Hello,
I have only two files.

a crt and the private key

My new file only contains…

----BEGIN CERTIFICATE ----

–END CERTIFICATE -----
---- BEGIN RSA PRIVATE KEY -----

---- END RSA PRIVATE KEY -----

Maybe I need to use another tool to create SSL certs for test environment

Here is some information from the docs:

https://documentation.xojo.com/topics/web/ssl_for_web_apps.html

i found something about here

for some reason with other https issues i had to clean up browser cache in firefox.