Problem using labels and hosting in WebApp

Hi,

First problem:
I’m about to write a webapp, which add some container-controls with labels to another container control - quite simple

Now I have the issue, that the labels not drawn correctly:

look here

The Locking is also set right!

I tried to add other containers - same result, I tried it also to change the styles - same.

Second Problem:
I’ve hostet this app on my webserver. All my other apps working fine, this app do not!
look here

I have the right port, the right permissions, etc. - still not working!

Whats the reason for this problems? It looks like a issue in xojo, doesn’t it?

happy new year

Lars

Think I’ve seen something similar some time ago. What happens if you do not set the label to Multiline?

Does this app has a unique Application Identifier so it doesn’t bump into another app using the same? :slight_smile:
It seems like you have a “space” in the URL. Maybe that could cause issues?

-> just tested - same :frowning:

sure!^^

no other ideas? :frowning:

I have now changed the SuperClass of one of these labels to WebTextField and the Text is drawn correctly!

It seems, that this issue only occurres on labels. It also seems, that every text in the labels are placed at bottom in the label.

Please Support, help me! :smiley:

What is the height of the labels in comparison to your text at runtime? (check in mousedown or some other event) I’ve only seen this when the label height was not great enough to fit the styled text. (Possible test, remove the style from a single line and see what happens?) “Uberschrift” is in a label yes? If your labels are ‘tall’ enough, and “uberschrift” is also a label, something is conflicting with the chosen label styles, for the cut-off labels.

Upon further investigation and a handy search…as I suspected the style you’ve chosen is not being applied correctly.

https://forum.xojo.com/5984-label-text-cut-off/0

A possible fix (has worked with other style related Xojo bugs) is to remove the style options from the visual style creator (for the chosen label style) and leave the style empty. In the App.Header, add a CSS style and name it the same name as your style created in Xojo. (We’re creating the style in the header, not the Style editor…which has the bug). Now, set the label to the chosen style using the Property Inspector in the web layout editor. Does it display correctly when run? This ‘forced’ styling also works great to implement style options not available in the visual style creator :slight_smile: I’ll cross my fingers for you…

Hi Matthew,

thanks for your reply. But I’m not particularly thrilled of your proposed solution :slight_smile:
In this project I have over 20 different styles and I really don’t know which style is broken (or if there is a style, which is not broken). The label is also drawn false - with no applied style and also with each other style.

I had the issue also in another project, if I added a containercontrol into another Container. If I added this container onto the “mainpage” the labels were drawn correctly!

Is this issue in relation with my hosting-problem?

By the way: on debugging the app is shown (issue 2) only if I compile it and load it on my webserver it’s broken!