Problem to publish an M1 application

I have compiled an ARM version of my app. RealCADD (but without scripts) which works fine on my Mac Mini M1.
I have tried to publish it on my web site to test but I can’t.
If I zip the app on my Mac Mini M1, upload, download and expand it. The app can’t be launched because damaged.
If I zip it on an intel Mac (upload, download and expand), the app can’t be launched because I don’t have the right to do it!?
You can try to download it here :
I have tried with AppWapper 4 but I have the same problem.
How can I resolve this?

Are the app and the zip signed? The “damaged” is the new way of macOS telling you that you need to remove the xattrs. This came up a couple of times in the last weeks.

1 Like

Have you notarise the file ?

On an AS device, the app needs to be signed. If you do not have a Apple Dev account, you can ask your customers to sign it.

xattr -cr pathtoapp
codesign -s - pathtoapp

EDIT: you already tried AW … so the only thing missing is notarising. As Valdemar said … you need to notarise the file otherwise it is marked as ‘damaged’. That’s not for ARM only. Also needed for Intel.

I have an Apple dev account and I use it with AppWrapper to sign AND notarize the app and an installer.
But I have always this alert :
You do not have permission to open the application

Can you explain how you notarized a zip file? Don’t think that possible.

There is an experimental feature in App Wrapper 4, that I would like you to try.

  1. Select the “Edit” menu, then “Advanced Options”.
  2. Click on the “Other” tab.
  3. Under “Additional Wrapping Commands”, enter in “-permissions reset” (without the quotes).
    Screen Shot 2020-12-31 at 9.40.20 AM
  4. Click on “Save”.
  5. Wrap the application.
  6. Now try the upload / download steps.

If that still fails to work, please share a link to the application and I will take a look for you (the one you listed does not work for me).

It is possible and App Wrapper 4 does so.

1 Like

That changed. Because it was .dmg and .pkg only in the beginning.
Good to know it is possible for zip too.

Thank you Sam, that works.
And the link is again active.