Problem submitting to App Store

I must be tired. I had been through the procedure before, but this time, generating a build, zipping it and sending it through Application Uploader does not work.

Here is the error I get :

ERROR ITMS-9000: "Invalid Provisioning Profile. The provisionning profile included in the bundle elementaryletters [ElementaryLetters.app] is invalid. [Missing code-signing certificate.] For more information, visit the iOS Developer Portal."

I verified that the distribution certificate is installed in the keychain, and that the switch “Build for App Store” is Yes in the build settings. I will appreciate assistance. TIA.

Gonna be a dumb question here… but you did have an iOS Certificate, not using an OSX cert?

I do have both installed. During beta I tried uploading a build and did not get that message. But I had placed the profile myself into the bundle. Of course I did not go further than the app uploader thing, as other error came and my app was just a test.

When I look in the bundle, the embedded.mobileprovision is there, though. Not many people have submitted apps yet, so I hope Xojo who has had an app approved already can assist.

  • There are no dumb questions.

My app made it in and approved. I only have ios certificates. I built with 2014r3, not yet 2014r3.1. I have not redone my certificates to get past the "distibution profile is required… " error building in 2014r3.1. I did not zip my app before uploading it.

Xcode 6.1
OSX 10.9.5
Xojo 2014r3

[quote=157643:@Scott Siegrist]My app made it in and approved. I only have ios certificates. I built with 2014r3, not yet 2014r3.1. I have not redone my certificates to get past the "distibution profile is required… " error building in 2014r3.1. I did not zip my app before uploading it.

Xcode 6.1
OSX 10.9.5
Xojo 2014r3[/quote]

OK. Thank you. I will try with R3 and if it does not work, I guess I will remove the distribution certificate and generate a new one.

How did you upload the app without zipping it ? Application uploader won’t let you select it ?

In Application Loader, in the Template Chooser window, clicking the Choose button allows me to select my .ipa file. No zip necessary. Using the Import button does not allow me to select the .ipa file.

Ah, that is what the Ipa is. I did not realize it was meant for that. Thank you.

No luck with R3. I am going now to remove all certificates and profiles, then start over with the “Submitting to the App Store” Xojo guidelines, and hope it will be alright.

Did you try uploading the .ipa file now. Maybe the first error was from trying to upload the .app development build of the app.

I zipped it, and the executable was recognized. From the error reported, it is apparent the issue is more a question of signature. I will try the ipa, though. If it works, I will report. Thanks.

The saga continues. I have followed everything step by step again.

Now all today I tried to send the app with Application Uploader and all I get is :

[quote]Application Loader is currently unavailable
We’re having trouble connecting to the App Store. Please try again later.[/quote]

:frowning:

iTunes connect was having trouble updating stats today also. There must have been something going on.

The problem is still with something I must have been doing wrong. I took the older version that does not have the proper provision profile, and it goes through API usage. It seems to be an app ID issue, this time.

I am going to take a big breath, remove everything and start anew. I use to zoom through the MAS, this hurdle is kind of a humiliating trauma :frowning:

I know I will get through eventually…

This is all so frustrating.

  • I have created iOS Elementary Letters ID with bundle com.matchsoftware.*
  • In my app, the ID is com.matchsoftware.elementaryletters
  • I made sure to create the proper profile, downloaded and verified it is installed in Xcode

Now here is what App Loader says in red :

No software with CFBundleIdentifier of 'com.matchsoftware.elementaryletters' exists.  Verify your bundle identifier is correct.  If it is, you may need to log into iTunes Connect to create the application.

I am a bit destabilized by recent events in France, so that maybe it, but I fail to see what’s up.

I tried creating an ID in app dev with the explicit com.matchsoftware.elementaryletters. Same result.
In complete despair, I entered com.matchsoftware.* in my app ID build setting. Same result.

What is going on ? Is there really no way ? I will appreciate any assistance.

For me it never worked when using com.company.*
I just use a ‘*’ and that works fine.

Sometimes telling grief helps alleviate it.

I think I found where the error was. I had followed scrupulously the Xojo guide “Submitting to the App Store” and did not understand where I could have gone wrong. Since the error message mentions Itunes Connect, I then proceeded to look for a place where the ID is mentionned in th description of the app.

Sure enough, it is in “more”/About this app, where the ID was set to XCode . When I set the proper com.matchsoftware. and entered elementaryletters as suffix, it does not take it. So I went elementaryletter (no s), and it takes it.

Now it uploads. Fingers crossed. I do get a warning that there is no 64 bit support.

Hey. An images 120x120 is missing. Back to Photoshop :frowning:

[quote=158561:@Christoph De Vocht]For me it never worked when using com.company.*
I just use a ‘*’ and that works fine.[/quote]

Will keep that in mind. Thanks.

The adventure continues…

Now App Loaders complains again :

I say, no matter, I will just add that. So I noticed there was no iPhone602x.png, and I proceeded to add it into the navigator App Icon folder.

No luck.

Then I said, OK, I am going to add the format directly, so I added iPhone120.png.

No luck.

I looked into the bundle. Interestingly enough, there is a file named AppIcon60x60@2x.png but it is 80x80 instead of 120. It looks very much like a bug, since AppIcon60x60@3x.png is rightfully 180x180.

I am going to replaced the faulty AppIcon60x60@2x.png by a 120x120 with a copyfile.

That was it. For some reason, Xojo placed an 80x80 image into AppIcon60x60@2x.png instead of 120x120. So copying the right picture into the bundle after build fixed it. Now the app is in review.
Phew.