Problem running apps on Armv7 Board

Hi I have a single board computer with a ARM processor 32 bit running Debian GNU/Linux 7 (wheezy). Ive installed all the libraries that were in the System Requirements but I am still not able to run a Hello World console app that has been built for ARM 32. These are my current results. If y’all have any suggestions it would be greatly appreciated. Running XOJO 2018R1.1 building from Mac

root@arm:~/HelloWorld# ./HelloWorld -bash: ./HelloWorld: No such file or directory root@arm:~/HelloWorld# ldd ./HelloWorld not a dynamic executable root@arm:~/HelloWorld# file ./HelloWorld ./HelloWorld: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.26, not stripped

Derek - which SBC is this?

VIA VAB-600 Pico-ITX Board

Whoa - at $99 for the basic board that’s a pricey bit of kit. While it doesn’t answer your build failure, would you mind sharing the choice of this unit over an SBC like the NanoPi M4 at $65 and far more options? I’ve just started digging into the realm of SBC’s beyond the Raspberry Pi and would really like to get an implementor’s insight on these other units.

We looked at a bunch of different options and have tried a few other boards but this one as the right IO, form factor, price point and power for what we intend on using it for. However if I can’t run XOJO apps on it then its back to the drawing board lol

Got it working. It requires armhf architecture, the kernel I was running was armel. Added the armhf architecture and added the libraries for armhf and everything is working now.

I’m so glad that we didn’t have to play those sort of games moving from 386 to 486 to Pentium, etc …