PrintingPicture.xojo_binary_project has a bug

The example project PrintingPicture.xojo_binary_project seems to have a bug.

I did not modify it and simply tried to run it.

  • It shows error shuttlelaunchsts100 does not exist when it is part of the resources
  • it says parameters not compatible with this function in line 10 g.g.DrawPicture(shuttlelaunchstsbig,(g.Width-shuttlelaunchsts100.Width)/2

I am surprised that an example provided with Xojo could not be working, and was assuming such program was throughly checked before release. It is quite unsettling to seek help from an example program, just to find out it is not working.

Is there something I should know ?

Will strongly appreciate help.

TIA

The picture names are incorrect, remove the underscores from shuttlelaunch_sts100 and shuttlelaunch_sts100_big and the code will run.

Thanks doofus, I did just that and it worked beautifuly. I was so puzzled by the whole thing, I looked at the code and could not find any error. I should have though about the picture names but it evaded me;

I suppose that what happened when the package was put together at Xojo. Hope they fix it in the next release.

They most probably won’t unless you put a note for them into their bug database, using their Feedback program.