Ports not read from command line

Today I try to just get a sample app running (Eddies electronics) on a new web server. For some reason Xojo doesn’t open the ports. See terminal window:

root@ubuntu:/var/www/html/eeweb# sudo lsof -nP -iTCP -sTCP:LISTEN
COMMAND    PID            USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
systemd-r  593 systemd-resolve   14u  IPv4  28501      0t0  TCP 127.0.0.53:53 (LISTEN)
sshd       668            root    3u  IPv4  29839      0t0  TCP *:22 (LISTEN)
sshd       668            root    4u  IPv6  29841      0t0  TCP *:22 (LISTEN)
/usr/sbin  676            root    4u  IPv6  28624      0t0  TCP *:80 (LISTEN)
/usr/sbin  676            root    6u  IPv6  31751      0t0  TCP *:443 (LISTEN)
/usr/sbin 2445        www-data    4u  IPv6  28624      0t0  TCP *:80 (LISTEN)
/usr/sbin 2445        www-data    6u  IPv6  31751      0t0  TCP *:443 (LISTEN)
/usr/sbin 2446        www-data    4u  IPv6  28624      0t0  TCP *:80 (LISTEN)
/usr/sbin 2446        www-data    6u  IPv6  31751      0t0  TCP *:443 (LISTEN)
/usr/sbin 2447        www-data    4u  IPv6  28624      0t0  TCP *:80 (LISTEN)
/usr/sbin 2447        www-data    6u  IPv6  31751      0t0  TCP *:443 (LISTEN)
/usr/sbin 2448        www-data    4u  IPv6  28624      0t0  TCP *:80 (LISTEN)
/usr/sbin 2448        www-data    6u  IPv6  31751      0t0  TCP *:443 (LISTEN)
/usr/sbin 2449        www-data    4u  IPv6  28624      0t0  TCP *:80 (LISTEN)
/usr/sbin 2449        www-data    6u  IPv6  31751      0t0  TCP *:443 (LISTEN)
/usr/sbin 2450        www-data    4u  IPv6  28624      0t0  TCP *:80 (LISTEN)
/usr/sbin 2450        www-data    6u  IPv6  31751      0t0  TCP *:443 (LISTEN)
root@ubuntu:/var/www/html/eeweb# sudo /var/www/html/eeweb/eeweb --port 48000 --secureport 48001 --MaxSockets 50 --Logging /var/www/html/eeweb/eeweb.log --NetworkInterfaceIndex Loopback --SecureNetworkInterfaceIndex Loopback
The servers could not be started. Please check to see if ports  are already in use.
root@ubuntu:/var/www/html/eeweb# sudo /var/www/html/eeweb/eeweb --MaxSockets 50 --Logging /var/www/html/eeweb/eeweb.log --NetworkInterfaceIndex Loopback --SecureNetworkInterfaceIndex Loopback
The servers could not be started. Please check to see if ports 8000 and 8080 are already in use.
root@ubuntu:/var/www/html/eeweb# sudo /var/www/html/eeweb/eeweb --MaxSockets 50 --Logging /var/www/html/eeweb/eeweb.log
The servers could not be started. Please check to see if ports 8000 and 8080 are already in use.
root@ubuntu:/var/www/html/eeweb#

As you see apache is running. All higher ports are not used. Then I run with port 48000 and get an error, that the ports are not available. See that there are no port numbers listed!
When I add print command to show app.port and app.SSLPort, they are both 0. As if the command line parsing is completely broken.

If I leave away parameters, it tries port 8000 and 8080 as set in the IDE, but these ports also don’t work.

Does anyone have a clue on what may be going on?

I’m not sure if a configuration blocking ports (for security) will make this happen.
Have you tried stopping Apache and running your web app with ports 80 and 443?


Edit: I missed that the = was not there. Glad that you found the problem.

Solution:

–port=8000

the = signs are missing for all options!

3 Likes

The command line parsing for Web apps is funky.

Edit: Ah, see you’ve discovered it.