Plugin Error : This item does not exist

I just installed Windows fresh and copied the MBS plugins to the Plugins directory and trying to compile the project. Its giving me error This item does not exists. Any ideas what’s happening. The MBS plugin is autocompleting in the project as well. So its not the MBS Plugin in the correct path.

Usually when I get such then some plugin is in Error state. Its not good that Xojo cannot report what the problem is, but that’s how it is.

In your case since your not developing plugins then more than likely your missing dependent plugin maybe, which puts one of your plugin in error state.

Did you install the same version of Xojo that you were using before?

Make sure you use the return value if the method has any…
not sure where the error is since you didn’t provide a screenshot or the code that is part of the error …

I installed the latest Xojo 2021 r2.1 and only copied the MBS plugins to the plugin folder. I can see the MBS plugins are showing the installed plugins in Xojo and its autocompleting the functions. This error comes when compiling and it was working before i reinstalled windows. I tried to clear the cache folder aswell. Still i am getting this error. No idea what to do.

Let me ask it this way… are you using the latest MBS plugins as well? Or something relatively new?

I am using the latest MBS Plugins ver 21.4 pr2. I tried with 21.3 also and same result.

Few things can be:

  • you have classes, modules, methods or properties etc which are the same name as a item in a plugin.
  • You have a method or property and you don’t use it’s return value

How to inform us better:

  • You show us a screenshot on macos CMD+SHIFT+4 and select the area of the error

What is the actual message that is being shown?
“This item does not exists” this can’t be the only part ?


Hi Christian, can you help oud friend @Sunil_Abraham ?


There is not much I can do.
On Windows, if you install too many plugins, not all get loaded.
And when you clear caches including Xojo scratch folder and precompiled plugins, Xojo may recover after you restart it and try again.

I had only few of MBS plugins in the xojo plugin folder and also tried to delete the xojo cache folder. The project is workig perfectly on another machine. What i noticed is that when it compiles its only compiling the plugins for xojo and eingur. But mbs plugins are showing and autocompletes. I have no clue where to check now.

The Visual Studio Runtimes are up to date?

You can download them here: The latest supported Visual C++ downloads or direct download.

Xojo automatically installed those runtimes while installation. But i will try to delete the runtimes and install it again.

You can be sure the runtimes are fine, the fact he gets auto complete means the Xojo was able to open up the plugin, which means the runtime is fine.

You don’t need to uninstall them.
You can always just overwrite them.

Nearly all plugins need 2015 version, but e.g. ChartDirector needs a newer one.

I tried installing the vc++ 2019 and still the same issue. Here you can see the MBS plugins are autocompleting
Screenshot 2021-08-13 092116
At the time of running or compiling its giving this error
Screenshot 2021-08-13 092324
This is happening for all third party plugins like MBS and Einhugur. I am totally clueless. Anyone from Xojo can help me as i have a pro license and hope to get a priority support.

What plugins from us are in the plugins folder?
Can you post a screenshot?

See also Feedback case:

These are the only MBS plugins i have
Screenshot 2021-08-13 113659

What is in Plugins folder beside MBS folder?

I put those plugins into plugins folder for Xojo here on macOS and Windows and didn’t run into an error.