Please help me testing Arbed - final 1.7.0 ready

Do you have any VCP projects (those ending in .rbvcp or .xojo_project), i.e. not XML nor binary RBP projects?

Then please download my program Arbed and open your project(s) in Arbed. If it opens a window, showing your project in it, all is fine, and the test is finished.

But if you get an error message that Arbed does not fully understand your project, then please send me the file that Arbed creates. It is a text file, so you can verify for yourself that it’s not containing sensitive private data before you email it to me (to tempelmann@gmail.com)

Get Arbed here:

Mac OSX: http://files.tempel.org/Arbed/beta/1.7.0/b9/ArbedMac.zip
Windows: http://files.tempel.org/Arbed/beta/1.7.0/b9/ArbedWin.zip
Linux: http://files.tempel.org/Arbed/beta/1.7.0/b9/ArbedLinux.zip

Of course, you may also report other bugs to me, but this is mainly to focus on VCP reading issues as I have outlined recently here:
http://blog.tempel.org/2013/09/XojoFileFormats.html

Works seemingly well for me on two separate, large projects, Thomas.

I have fixed all the reported issues in the latest Arbed beta related to VCP and Xojo projects:

http://files.tempel.org/Arbed/beta/1.7.0/b10/

If you have not tried it yet, please open your Xojo projects in Arbed once and let me know if it reports any errors.

Thanks!

Tested with my main (personal) project and it seems to open fine. That project has not yet been moved to Xojo though. File format is rbvcp.
Projects at work are Xojo but not VCP, they are xml files. Those loaded fine as well.

Aaaand b12 is out fixing these issues:

  • Unavailable external files such as images had caused a verification error
  • Cursors had caused a verification error

http://files.tempel.org/Arbed/beta/1.7.0/b12

Is Arbed.exe supposed to be changing file associations under Windows? After running the beta, several RB/Xojo extensions (rbo, e.g.) are associated with Arbed.

Yes, Arbed associates with them because it can open them. Do you see a problem with that?

Yes, but not a huge one. Arbed associated these extensions with a temporary file that I subsequently deleted.

I forgot to mention that when unzipping on Windows it complains about an invalid filename ‘Scripts\Add “#pragma unused”.arbs’
Doesn’t seem to stop Arbed from running though.

[quote=36073:@Dirk Cleenwerck]I forgot to mention that when unzipping (with winzip) on Windows it complains about an invalid filename ‘Scripts\Add “#pragma unused”.arbs’
Doesn’t seem to stop Arbed from running though.[/quote]

Dirk, I’ve fixed the issue with the “#” file. Turns out that it was not finished anyway, so I simply removed it from the archive.

Andrew, I don’t understand what you mean.
There’s a temp file that is associated to Arbed, and then you delete it. I don’t see the connection that could be bothersome.

I extracted the beta version to a directory on my desktop, ran the beta and then deleted the directory when finished. Arbed associated the extensions with the beta exe that was in the directory I deleted.

Ah, you deleted Arbed.

Any suggestion how to do this better? I have to add these associations somehow, but sadly Windows doesn’t have automagic filetype (dis)association handling as Mac OS does. Or is there something new in recent Windows versions?

The only way I know would be to use an installer and also provide an uninstaller for this, right?

That’s how I do it. I use Inno Setup to create necessary registry entries in my app’s installer. The uninstaller Inno generates will remove any registry entries the installer creates (unless told not to.)

Inno Setup is easy, I’ve used it for 12 years, just start with an example and work from there.

Aaand a new version is ready, fixing another two VCP issues:

  • Reports led to a (harmless) verify error
  • Icons in MenuItems were not handled

http://files.tempel.org/Arbed/beta/1.7.0/b13/

Alright,
I am very close to releasing a final version now.

b15 is ready and has a lot of important improvements:

  • No more flicker on Windows.
  • On Linux, cmdline mode works, finally.
  • Comparison marks differences in encrypted items and of the “dynamic” state of constants.
  • “Minor differences” (i.e. those that do not affect your code but are just random inconsistencies in the project file, caused by the IDE) are much better identified now, which also makes the “Ignore 1-sided PDEFs” option obsolete.

Get it here and let me know if you find any issue with it: http://files.tempel.org/Arbed/beta/1.7.0/b15/

i used it for many year. i study the iss file and create my own script. then i run the iss file with a command line innosetup.

The invalid filename ‘Scripts\Add “#pragma unused”.arbs’ is back in the Windows zipfile.
Was fixed in a previous beta.

I’m also having several problems with this beta (on Windows 7 64-bit, Dutch language)

  1. After having dragged a project to the Arbed Drop Pad, Arbed opens the project Window. After that I seem to be unable to use File Exit in Arbed. I can close the window with the top right x, but then Arbed remains in memory and I have to use the task manager to shut Arbed down. If I haven’t opened a project yet, the File Exit works

  2. Sometimes using File Exit actually crashes Arbed (haven’t been able to reproduce reliably, but it happened more than once). I’ll e-mail you the report.wer crash report. Maybe you can see something there.

  3. Switching on “enable debug messages” under preferences seems not to do anything. No Arbed-DebugLog file is created on the desktop.

  4. I’m noticing a difference with externals items in xml with this beta (b15) as compared to the release version (1.6.3).
    The beta notices something the release doesn’t, but even the beta seems to be a bit inconsistent with what happens. Hopefully this can be improved.

Hopefully the following description should explain what I see.
We use Microsoft Visual SourceSafe with a project that is full of external xml items (using Xojo 2013r2) for its windows, classes, modules…
This means that the main file (RBMain.xojo_binary_project) is locked by SourceSafe. In fact all files are locked by SourceSafe unless we check them out. Since you can’t work with a locked project file in xojo (it will lose any changes to checked out files, since the project file can’t get updated), our workflow is as such.
a. Start SourceSafe
b. Get Latest version of all project files
c. Open the RBMain.xojo_binary_project file in Xojo
d. Save this project as RBMain001.xojo_binary_project
e. Close Xojo (to prevent thing going wrong, because at this point sometimes Xojo seems to think that the new RBMain001.xojo_binary_project is also readonly even though it isn’t.)
f. Open the RBMain001.xojo_binary_project file and start working

Now when opening RBMain.xojo_binary_project or RBMain001.xojo_binary_project, Arbed seems to be handling it fine.

When opening RBMain.xojo_binary_project and the RBMain001.xojo_binary project by dragging them on Project Comparison, I get a lot of warnings about External Item… Inconsistent file references on both files, even though we have just saved the RBMain001 project so that is should be a perfect copy of the RBmain file with the same links to the external files. The project comparison window then is to empty other than references to encrypted file that it can’t compare and buildflags, as expected, since the 001 file is a copy of the main file.

If I then close the comparison window and drag the two files to the project editor, Arbed opens the projects, and most external files show up as External (Code) with a ResolvedFilePath. I then do not get to see the code in these windows, modules, classes at this point, since the project editor on the right does not show me the code, but the ResolvedFilePath instead. Hopefully this can be improved, since the file location seems to be resolved.

Some other files show up with <ambiguous [multiple files found]>. These seems to be the files that show up when dragging the files to compare projects. So it looks like the beta signals that there is a problem when comparing the files, whilst the release version didn’t say anything. What I do notice is that if I close the comparison window in the release version, and open one of the projects again by dragging it to the project editor, I also get the <ambiguous [multiple files found]>. When I rightclick the file and choose “reveal on disk”, it does show the file, and it is the same file on disk. Since both projects seem to correctly find the file through “reveal on disk”, I don’t think there should be any ambiguous files. Maybe the file names are encoded differently?

That’s what I have so far.

Dirk, thanks for all the feedback.

I’ve identified why the bad file name came back. It’s kind of a weakness in Xojo’s build process, leaving old data in there, with no easy way to prevent it. Fixed now properly and uploaded a new b15 with a fixed zip file.

#1. About Arbed remaining running. That’s odd. Not happening on the Mac. I’ll investigate.

#2 Ah, that’s what the report was about. Unfortunately, the report does not even contain a stack trace, so I can’t tell anything from it.

#3 There are currently not many debuglog producing calls active, that’s why you don’t see any output.

#4 - I’ll look into that later.