pgSQL4RB Update


I have an application that I’ve developed over the past decade or so that extensively used Aliacta’s pgSQL4RB add-on. I need to start transitioning to the Xojo platform; but, I’m getting errors about some things in pgSQL4RB that are deprecated (StaticTexts, MemoryBlock, etc.). I’ve sent an email to the support address for Aliacta, but I haven’t received a reply. I would REALLY like to not have to refactor the application away from pgSQL4RB.

Does anyone know if Aliacta is still operating? Does anyone know if Marc is still there?

Any information would be greatly appreciated.


pgSQL4RB is all encrypted classes too isn’t it ?

Its been ages so I dont remember

I too am a long time pgSQL4Rb user, and have not seen anything happening for quite a while with Aliacta. You can remove all the bound GUI classes and it works on more modern versions of Realstudio, but I don’t think it ever worked with Xojo, or at least Xojo with Cocoa. It threw a weird error that basically refused to compile but never told you what the actual issue was.

I ended up refactoring to use the built in Xojo DB classes, they work fine, but still not what pgSQL4RB was.

If the classes are encrypted then errors are basically reported as “there’s an error in here” because the code isn’t supposed to be revealed hence why its encrypted

Too bad it’s not updated

Thanks for the information, Norman and Jason.

Yes, the classes are encrypted. So, I can’t dig in and fix the problems.

Jason, I too removed the bound GUI classes when REALbasic moved away from the visual binding. Which is the feature that really sold me on REALbasic and pgSQL4RB to start with.

I do have some surprising news… I was developing on RB2010r3.1 because when I tried to move to RB2012, I got a couple of deprecation errors. Namely that the pgSQL4RB caches were using NewMemoryBlock and pgSQLlabel was a subclass of StaticText. I naturally assumed that Xojo would be further along in the deprecation of those two issues. However, I just tried a simple little project in Xojo2015r4.1 and everything worked! No complaints about deprecation issues like RB2012. I guess Xojo must be internally dealing with the deprecations.

Hi Mark,

That sounds great on 2015r4.1, I will give it a try. Out of curiosity, what OS are you running on / testing the simple project on?

This is more likely the IDE not warning you about something you cannot do anything about because the code is encrypted

Jason, Windows 7.


I tried a new project (without the pgSQL4RB classes) in both Xojo 2015r4.1 and RB2012r2.1 with a single Label that I changed the superclass to StaticText. In the window’s Open event I put:

[code]Dim mb As MemoryBlock

mb = NewMemoryBlock(16)

Xojo2015r4.1 complains that StaticText is deprecated; but does not complain about NewMemoryBlock.
RB2012r2.1 complains that both StaticText and NewMemoryBlock are deprecated.

Sounds like a possible oversight and that my code is running on borrowed time.