Permissions trouble

Having a nightmare trying to get my blinker app to run. The problem seems to be that the permissions are frozen to 644. Double-clicking the file asks what program I should use to run it. Also tried setting permissions to 755 with “chmod -v”; it reports that the permissions have been changed to 755, but then if you run “ls” on it, they’re still 644. (Changing permissions in the GUI was no more successful.)

Did you run that chmod with sudo?

Tried it both ways (with and without), same result.

Arm32 bit selected in the build settings?

Yes, I think–will double-check when I get home.

Permissions not changing even when using sudo is a sign something is wrong with the OS.

A common symptom of a bad sd card is that writes to the card begin to fail. I had a PNY card that started doing this. Things mostly worked fine, but stuff would “disappear” and it was quite confusing at first. I cloned the card to a different one and things worked fine after that. No other changes were needed. That’s the first bad card I had like this too, but this was a fairly well used server.