Pasting Excel values into a constant

I’m on 10.6.8

In RealStudio days I would copy and paste data from an Excel spreadsheet into constant which I parse in code… Copying from Excel always gave a Tab delimited string.

Just tried doing that in Xojo and I got a strange result… Initially the text shows up as a grid in the (I assume) cocoa textarea in the IDE. If I try to edit it or move away and come back, the grid disappears BUT so do the tabs, and I get one value on each line losing the column structure.

I tried first pasting from Excel into TextWrangler. That worked as expected. Then copying that from TextWrangler to the IDE DOES work as expected as well…

Excel probably puts multiple datatypes on the clipboard and the Cocoa TextArea is picking one which Cocoa supports but Xojo does not, so when you access it you lose the 'table" column structure.

I assume this is a bug? It certainly is strange!!!

What happens when you paste the data in a listbox? On my pc in a listbox it pastes everything nicely in every cell.
If i paste it in the initial value window of a textarea it also pastes just fine but as soon as i click the ok button to place it in the actual textarea then indeed all tabs are gone.

Certainly a bug IMO.