Parallels 14.1.3

For my windows developments I use Windows 10 + Xojo 2018R4, running on a Mac (EL CAPITAIN 10.11.6) using Parallels. Up till last weekend I used Parallels 13.x.x and had no issues with that configuration for a long time. Last weekend I have been tempted to update my two Mac computers with Parallels to it’s latest version, 14.1.3 (45485). From there off I have a problem with Xojo, die out every second or third time I compile (Ctrl-R) one of my projects. No matter if it’s big or small and it dies when the progressbar is nearly half way. Since I have good experience with Xojo 2018R4, I do not suspect Xojo for this issue. I tried quite something within Windows 10, like switching off its defender/firewall etc. Yelling to Parallels with this matter will not impress anybody there, my previous version is not for downloading anymore, so I am afraid I have to rollback the diskimmage I took just before updating Parallels. (luckily).
Q: does anybody seeing the same ?

No idea about that since I am not using Parallels.

However you can download the last version 13 using this link

Go to your personal account at Parallels (
Login and on your Dashboard page click on the cloud with the arrow down underneath the text “Parallels Desktop for Mac”.
At the top-right side you see a dropdown menu with Version: 14
Click on that dropdown menu and select the wanted version.
The page is updated with all the installation files and documentation for that version.

still curious if I am the only one seeing this behavior of Xojo while using the latest version of Parallels.

Btw: the difficulty with downgrading Parallels itself can be that the VM’s are treated with the newest version, so how far reliable when using these VM with an older version of Parallels.

I’ve had no issues with 14.1.3
I’m on macOS 10.12.6

[quote=432381:@Norman Palardy]I’ve had no issues with 14.1.3
I’m on macOS 10.12.6[/quote]
Since I had the problem with the latest version of Paralels with two computers running macOS 10.11.6, I believe the newest Parallels is just not stable for this version of macOS. Beside with Xojo I ran in more problems with the VM’s, like very unstable VPN connections, Windows dialogs disappearing just by staring at them etc…
I rolled back the Parallels update and all the VM’s and seem to be stable again.
Good moment for reconsidering my auto renewal Parallels subscriptions., since they didn’t even response to my polite support request 3 days ago.

No issues with 14.1.3
macOS 10.14.4

Although I am within the Parallels requirements with MacOs 10.11.6 on late 2012 Mac’s , I still believe that they had better dropped support for this version of MacOs. Since I use these machines mostly for windows developments I don’t have a good reason to upgrade MacOs, EL CAPITAIN is just suitable an stable for me.
I have rolled back my VM’s and Parallels and am back stable again. I just pause my subscriptions for these mac computers till they day I need to renew hardware coming with the latest OS.

may be you can download a demo of vmware fusion, import your parallel vm inside, and see if it works or not there ?
the demo works for 15 days or even 30.

Well Jean-Yves, in fact I had no reason for updating others than staying up-to-date. So, rolled back and be happy again. :slight_smile:

@Joost Rongen — “If it ain’t broke, don’t fix it”. This is the most sensible proverb nowadays.

[quote=432575:@Jean-Yves Pochez]may be you can download a demo of vmware fusion, import your parallel vm inside, and see if it works or not there ?
the demo works for 15 days or even 30.[/quote]
Fusion is/was a LOT slower than Parallels for some tasks - one of them was VM’s with Xojo installed

As Norman said, some solutions are slower than others. I guess it all depends on the money you can spend.