Oracle tableSchema

I need to be able to connect to a client’s Oracle database and extract data from it within a Xojo application. I am able to make the connection with the Xojo Oracle Database plug-in. Unfortunately, this is a fairly large corporation, and their are many layers between the person with whom we are working and the DBAs. Getting information about the database is very difficult.

In an attempt to get information myself, I’ve tried to use the “TableSchema” and “FieldSchema” methods of the OracleDatabase object to gather basic information about the database structure. When I execute “TableSchema,” I get back a non-nil recordset, but it contains no records.

Having very little experience with Oracle, I wonder whether this is likely to be a permissions issue on the account with which I’m logging in, or something else.


Have you tried to query the internal Oracle Dictionary?


for more info

link text

Thank you, Dave!

I did eventually get it to work. I couldn’t use “SELECT * …” as the db object complained about some sort of mis-matched datatype issue (“expected BLOB, but got BINARY” or some such). But, after looking over some other Oracle docs, I was able to explicitly reference the fields in which I was interested (“SELECT TABLE_NAME, COLUMN_NAME, DATA_TYPE FROM ALL_TAB_COLUMNS”), and it worked.

Thanks again…