ORACLE; insert does not work


I can connect to an oracle database and get data.

But no insert works, nor by SQLExecute nor by DatabaseRecord and insertRecord.

Is there a reason for that known?

I am specifying null values and do no Commit(); or is Commit() needed?

Then, db connection is immediately closed after insert.

Any hint?

Thanks a lot in advance!

So, I used ODBC with ORACLE provider and insert worked!

I can confirm for decades: ORACLE was and is really a mess, indeed, really;-)

post the code so we can see what you are really doing

I am going out on a limb and ASSUMING that you are in fact checking for errors and that there are none???

Yes, I am checking for errors.

I got ODBC running.

Problem was, tnsnames.ora entries must be in one line to work with ODBC (in my environment).

Posting code is always better; I was hoping that there is a general problem known.
Something like “only use DBRecord.InsertRecord()” or something similar.

I want no one spend hours for solving such problems.


Well good luck… we can’t help you unless we have an idea what you are in fact doing…
I don’t mind spending time helping solve a problem. what I do mind is wasting time chasing the problem

Until You can not tell “yes, I know, the problem could be…” such a post can be overread.

Even when no source code is included, I accept not a good help my be given.

The good thing is: this little problem doesn’t keep me away from using Xojo.
I’ve thrown together an app and could not get unprofessional as Xojo keeps many things in order (of course, understanding a little bit of OOP needed).

Next time I will give some code when having a problem; so solving the problem can start directly.

Really appreciate this forum and its helpful guys!

Ok; solved as I needed it again.
DB.Commit() is needed as even in SQL developer, insert needs a commit (while update doesn’t).