Open/Save Dialogs Not Showing Favorites on El Capitan

Before I create a bug report for this, has anybody else noticed Open and Save dialogs not showing the favorite locations list?
I’ve checked in the IDE, and a couple Xojo created apps. The Shared section is there, Favorites is not.

I wanted to check with everyone else first because it could be me. I just migrated from my MacMini to a different machine, and upgraded to El Capitan in the process.

Do they appear in other applications correctly?

No… It appears to be me.
But the bug presents itself differently in Xojo apps vs. native apps.
In Xojo and the like the Favorites section is entirely not there, while other apps show just Recents under Favorites.

I’m investigating now. I didn’t know it was a system wide issue for me.

Don’t know if this is related or not, but I ran across a article that indicated that “Recent Files/Favorites” were by default disabled across the board for El Capitan as a “security measure”.
I discovered this using XCODE, there the solution was to delete a particular PLIST file (don’t recall which one) and restart XCODE.
If XOJO uses the same method, then I’ll be the solution/reason is also the same.

It seems to be a common problem, and I found a solution on stackexchange that has you delete your finder settings and relaunch finder. This however is proving no effect. My only option now is to reboot and see if that helps.

So far, not liking El Capitan.

Lo and behold, a reboot fixed it…

But now I’m curious. Why don’t Xojo apps show the Recents item under Favorites?

Oh dear… With Yosemite and onwards, any weird issues and you need to restart Windows, I mean OS X. I’ve never had such an unstable Mac as I did with Yosemite. Apple really needs to get a grip on the development teams, I saw several articles recently highlighting Apple’s bugginess this past year.

[quote=239166:@Tim Parnell]Lo and behold, a reboot fixed it…
But now I’m curious. Why don’t Xojo apps show the Recents item under Favorites?[/quote]
Are you building a 64-Bit Cocoa application? If so, then it might be because Xojo links to an older version of the OS. Anything else and it’s because Apple have unofficially depreciated it.

At least that’s the response I received for some of my Core Image bugs in 32-Bit.

I sure hope that in 2016, Apple really focus on stability across all products. There’s nothing quite like an iPhone that doesn’t produce any sound until you reboot it!

The issue (Recents being in other apps’ open dialogs) presents itself in 64bit (Answers) and 32bit (Xojo IDE)

Funny… AppWrapper shows the correct sidebar. glare

Holy crap I thought that was just me.

Ha ha… It’s a 32-bit Cocoa application… Weird man, just plain weird.

Nope, not just you, I’ve missed calls, texts, alarms and so on. I’m hoping the next update will fix this issue, but what other issues will it give me. The next phone I get, I will not update the software, not worth the hassle.