Office plugin not loading on 2022r1


I am posting here to see if someone encountered the same issue and solved it.

I am on windows 10, 64bits, using Xojo Desktop

The Office automation plugin does not load on 2022r1 while it loads on 2021r3.

The Office plugin has been copied from the extra folder to the plugin folder. But when Xojo is launched it only loads the “excelclasses”, “wordclasses”, “powerpointcalsses” and “vbe” but not “Office” (not listed in the About/List of plugins). In 2021 r3, “Office” is listed.

Any idea what is wrong ?



Hi @Pierre_Martinez ,

welcome to the forum !

Did you check in Windows logs if there are any entries that could tell what happened at the time Xojo was trying to load the plugin ? Did you get an error from Xojo, if so the text can be very long. If you can capture it and post it, someone may provide help.

Hi Gilles,

Thank you for exploring this matter. I did not find any logs in the system32 folders for this.

There is no error message when Xojo starts. It loads all plugins including the excelclasses, wordclasses etc. but not the “Office” one, and does not tell me that the Office plugin was not loaded. I can see in the About/plugin that it is not in the list.

I get a notification of bugs when I try to build my app which relies on the Office plugin, but this is the typical bug flag which is thrown when the plugin is missing.

I tried to add Xojo 2022r1 .exe in the list of apps authorized by antivirus but this does not solve the problem (see screen shot).


Same here on windows 11. I have copied the office plugin to the plugin folder and this error come while compiling. It shows error for only syntax. Is the Office keyword depreciated. If so what is the alternative. I don’t see anything in the documentation as depreciated.

Hello Pierre,

I had the same problem already in beta test on all my systems, not only Windows 10/11 but also on Linux and Mac.

Hope it get’s fixed soon.


I asked @Pierre_Martinez to post this issue to the forum because we have been so far unable to reproduce it here at Xojo.

His case: 68253 - office automation does not load

I have tried a Windows 11 laptop and a Windows 10 VM. William has tried a Windows 10 PC. I stilll have another Windows 11 VM and a Windows 10 PC to try, but so far in our tests the Office Automation stuff is loading and working as expected.

In an effort to get more clues as to what is causing this problem, I’d love to get more information from those who are having trouble. It would also be good to hear from anyone that is able to get it working.

You can provide information here or in the case.

I appreciate any help with this.

A guess based on my experiences with including office automation (Word, Excel) in the VBA with a Microsoft Access database: the version of office on the developer’s computer must be the oldest version that any user of the database will have.

The parallel could be the office automation plugin, if it expects a more recent version of Office than is installed, it might fail to load.

I hope this is helpful. I have no experience creating plugins. Just wanted to share some office version conflicts I’ve had, not related to Xojo.

Hello @Pierre_Martinez ,

The Xojo Office plugin works with the downloaded version of Microsoft office. Is it possible that the computer has the online version called office 365?

I am using Office Professional Plus 2021 (NO Office 365) and the Xojo Office plugin does not work.

To get to Windows Logs:

Right on This PC and select Manage:

Expand Windows Logs, and open one of the logs to look at the contents.

1 Like

Hello Paul,

please note that “Office” isn’t loaded on Linux and MacOS here, too!
And in windows 10/11 it does not matter if Office is installed or not, I tested with Office 2016 and 2019.
It did load in all prior versions of Xojo.
Can’t see anything in any logs.

The only explanation for me is something with localization?!


@Paul_Lefebvre easy to reproduce using a Mac:


as you can see Office is loaded in the previous version and not in the current version. Hope this helps.

Hi all,

Following Gilles’ advice I checked the logs on windows. I found this log generated at the exact time I launched xojo 2022r1. It says (translation): “Authorization parameters of the application do not grant “Local Activation” permission for the COM server application with CLSID”. Source mentioned is “DistributedCOM”

I do not know if this is relevant in this case.


Yes, Same COM Error, same Office plugin not working.

Windows 10 1903, Office 2016

I Googled [windows “local activation” COM] which returned many pages. This one could be interesting:

I wonder if the application is Xojo ?

@Paul_Lefebvre does this ring a bell to you ?

I wonder if the issue could be specific to some installations of Windows 10 ?

Windows 10 1904 x64
Office 2016

I get the same error and plugin does not load “Office”

Well tried it also. On Windows 10 21H2 19044.1586 March patches installed (Windows 10 has been reinstalled from scratch on a new drive about a year ago):

Xojo 2022r1 Office plugin is not loaded
Xojo 2021r3.1 Office plugin is loaded

I am not sure the Warning in Windows System Log is an indication since I got it only once, the first time I ran 2022r1.

Hello Pierre,

I have been in the Microsoft Forums and is reported to be a harmless issue. If your program does not run, then this is not harmless. It is almost like Excel was installed with limited ownership for Excel. I am guessing this may be installed on a business computer with special permissions for a user (?).

I don’t know if this will work, so be careful when making any changes to the registry. A possible solution is to open the registry editor (regedit), and navigate to the following registry key:

  1. HKEY_CLASSES_ROOT\AppID{2593f8b9-4eaf-457c-b68a-50f6b8ea6b54}
  2. right-mouse-click on the key {2593f8b9-4eaf-457c-b68a-50f6b8ea6b54} and select ‘Permissions…’
  3. In the Permissions Window, select the advanced button
  4. Click on the link ‘Change’ beside the words TrustedInstaller, and take ownership
  5. After taking ownership, go back to permissions and select Allow in the Full Control section.

Here is a link with some screen grabs to help with the steps: [FIX] Event 10016 Error, The Application-Specific Permission Settings Do Not Grant Local Activation Permission In Windows 10

Edit: Another person that had the exact same error said that they setup OneDrive and the error went away. This is a difficult error.

Hi Eugene

Thank you for this. I would want to avoid changing the registry. The problem only happens with Xojo 2022r1; if I run xojo2021r3 today, the problem does not occur, the office plugin loads and works. My conclusion is that the problem is with Xojo 2022r1 where something was changed compared to 2021r3. If Xojo does not find the solution I will try the method you proposed. Thanks! Pierre

1 Like