Odd problem when using a Wacom tablett

A couple of weeks ago I got a new Wacom tablett which I use instead of a mouse. Since then EVERY time I run my app in the Xojo debugger Mac OS asks me to add the driver app to the accessibility list:

Translation from German: Confirm the action by entering your password. If you want to disable the security check in future add “WacomTabletDriver.app” to the accessibility list in the system preferences. Enter your password to allow this.

But I’ve already added the app to the list:

What else can I do? I’ve already contacted the Wacom support but they didn’t answer. This is so getting on my nerves.

Did you remember to reboot your system, to ensure the changes were set?
You shouldn’t have to, but I have also run into this problem before.

Thanks for the idea, Richard, I’ll try that.

If that doesn’t work, take it back. Wacom & Apple seem to be at odds with each other over the OS security, which is acceptable. What isn’t is not responding to the customer when they bought your product and are asking for help (yes I know I can be slow to respond sometimes, but I don’t have a customer service department).

Once you’ve exchanged your Mac for a PC, your Wacom tablet should function as expected :slight_smile: It’s a little bit of ironic humor. I normally wouldn’t condone such as action.

@Sam: can’t do that. How am I supposed to work without my tablett? Can’t use a mouse because I have arthritis in the hands. I’ve been using Wacom for 17 years now and never had any problems.

I’m just going to do a global hotkey for the §$%& password. The computer is an old heavy MacPro that even the burglar didn’t want so I guess it’s save.

The odd solution isn’t to return the tablet, it’s to return your Mac and switch to Windows where the tablet should function as expected. Can’t believe that I’m actually recommend a Windows PC, what has happened?

#1 Uninstall the drivers that came with the tablet, then go to the Wacom site and download the absolute latest drivers you can get, make sure that they say 10.11 compatible. If not, then you’ll need to exchange the tablet for one that has drivers compatible with 10.11.

#2 You could also try turning off Apple’s System Integrity Protection.
http://osxdaily.com/2015/10/05/disable-rootless-system-integrity-protection-mac-os-x/

#3 Revert to a previous version of the Mac OS.

#4 The other thing that I did for my father-in-law, was to get a Magic Trackpad and a really good trackpad pen. It’s not great at all, but allows him to write Chinese characters as opposed to learning the rather complicated way of trying to type them. I wouldn’t suggest this as a ‘better’ solution than a Wacom tablet (as I know how good those are), but it’s an alternative.

#5 Show Apple how much trouble this has caused you, by not buying their products. I believe there’s a trend at the moment of people not upgrading and choosing alternative products because of the issues that they’ve had to endure over the last two years (hence why almost all of Apple’s hardware have dropped in sales, not just the iPhone or iPad).

  1. Try to enter the password and click OK with the mouse, not with the stylus.

If it doesn’t help (that is, the password question still appears):

  1. Try opening /Library/LaunchDaemons and delete com.wacom.displayhelper.plist file, then reboot your Mac.

If it doesn’t help, then I have no idea. I am using Xojo with Intuos from time to time and it works fine. I don’t remember it asking me for password and I don’t even have WacomTabletDriver.app added to the accessibility list.