Notarizing is killing me

Hi all,
I’ve been successfully code signing my Mac apps for some time now.
I cannot get them to notarize and I really cannot understand what’s missing.

Looking for an easy to follow command line option as that’s what I’ve been doing for the code-signing part so far.

I have tried App Wrapper and it isn’t working for me, and unfortunately the error messaging gives me nothing to go on.


DMG Canvas can do notarization and is very convenient.

There must be something like this:
Xojo Forums/“You must first sign the relevant contracts online.”

[quote=485009:@Chris Halford]I cannot get them to notarize and I really cannot understand what’s missing.


Did you get an app-specific password from Apple? That was what was stopping me. Once I got that, notarization (using AppWrapper) works great.

Tried DMG Canvas.

[quote]Uploading for notarization failed.
Error code -22016. We are unable to create an authentication session.[/quote]

Doesn’t give a lot to go on.

John, yes indeed I generated an app-specific password.

played around more. Now I’m seeing this error.

The username is not a member of the provider Chris Halford. Contact your team admin for assistance. (1296)

That’s my Apple ID. I’m not sure what they are looking for. Anyone?

I keep hacking around and now I’m getting the error.

I’ve seen this both in DMG Canvas and App Wrapper. I cannot see why I’m connected to multiple accounts, or how to specify one.


Had the same issue today. The solution is very easy: Log in to your Mac developer account (I think you must have one in order to code-sign your app). If you didn’t read and sign Apple’s new contract, you’ll be prompted to do so. Just read and understand the very lon text. :wink: Or scroll down and check “I’ve read all and agree…”. That’s all.

After having done so, I could notarize my app without any problem.

By the way: I use Sam Rowland’s AppWrapper for the complete process “Code-signing / Notarizing / Generating DMG canvas”. It’ very conveniant, and can be launched via an automatically generated post-build-step. On top, Sam Rowland is very customer-oriented guy who helped me out more than only once.

So the trick for me was to use the non-friendly version of the team name, and then it all worked.
Well a 3rd party Dlyib choked it, but I found that they had updated it since and I have my first notarized app… yay.

See also Bob’s article, which showed me the provider thing: Notarizing Your Xojo Apps