No @-sign on my keyboard! Clownfish is the answer...

Samsung Laptop, Windows 8.1
It’s no longer possible for me to press the @-key on the keyboard on my laptop.
On the Swedish keyboard, that’s the combination of Alt Gr + 2. Instead, now comes some kind of strange short cuts
for the speech control, that’s not available in the Swedish version of Windows…

I’ve done all the Updates as I can possible think of…
I think I must have hit some kind of short cut by accident, to turn it on. Now I want to hit that same short cut to turn it off!!
Please!! Tell me what short cut that is!!! :slight_smile:

Hi Jakob,

On some of the new laptops there are two new keys F-Lock and Num-Lock. Accidentally pressing one of these buttons will sometimes lock out the @ key. Press either one of these keys again and see if it works.

Not sure if this helps, but its worth a try. :slight_smile:

Edit: I forgot to mention the abbreviations: F-Lock means Function key Lock (F1, F2, keys), and Num-Lock is number key lock (1, 2, 3, etc.)


I make a new photo tomorrow in daylight.

There’s no F-lock, but Fn-lock that I assume is the same. There is no Num-lock.

Have you tried to reboot ?

I now tried with the external keyboard and it remains.
No good!

I made Windows Update.
“SW Update” , Samsung’s own update utility and updated some services… including Hardware Update (It’s called something and now I forgot what it’s called.)

I have rebooted numerous of times, yes.
It’s mainly the @, the £ and the $ signs and in Sweden we use the @ sign the most. Not the others.

I’ve also run some of my favourite software computer rescue tools such as Eusing Free Registry Cleaner, CCleaner, Internet Cleaner (Eusing) and the Defrag.

I tried all of that before asking the forum… !


I was hoping, I was thinking… Because it came for no obvious reason, it may disappear for no reason as well…!!
I am a believer!! :slight_smile:

I would try going into the Language Control Panel, add another language, for instance English, and remove Swedish.

Then reboot again to reset things, go back into the Language Control Panel, add Swedish again and make it default by placing it on top.

Hi Jakob,

Thanks for the picture, as this helps. Here are common ways to turn off the num-lock feature.

Fn+F11 (Acer, Toshiba, Samsung)
Fn+F8 (HP)
Fn+F4 (Dell)
Ctrl+F11 (HP)

The good news is that the key combination should be included in the manual from Samsung. If you let me know the model number, I can look it up for you.

I updated the BIOS, as described above, Not the “hardware update”…

The model is Samsung NP910S5J and really, it’s the fastest computer I’ve ever used!!! So neat! Because it’s an SSD drive! It reboot in like 8 seconds or so, simply amazingly fast!!

http://www.samsung.com/se/support/model/NP910S5J-K01SE
The SW Update. Use your imagination for the English version…!


I downloaded and installed the English (UK) keyboard, settings. Rebooted and the problem remains! So strange!
When pressing Alt Gr + 1, +2, +3 … all numbers as follow: (The short description show on the screen at the position of the mouse)

Alt Gr + 1: “Voice type: Alien (useless)”
Alt Gr + 2: “Voice type: Atari Game”
Alt Gr + 3: “Voice type: Clone”
Alt Gr + 4: “Voice type: Mutation (slow)”
Alt Gr + 5: “Voice type: Mutation”
Alt Gr + 6: “Voice type: Mutation (fast)”
Alt Gr + 7: “Voice type: Robotic Voice”
Alt Gr + 8: “Voice type: Pitch (male)”
Alt Gr + 9: “Voice type: Pitch (female)”
Alt Gr + 0: “Voice type: disabled”

Swedish keyboard as it should be. (1 and 6 are not used, are empty.)
Alt Gr + 1:
Alt Gr + 2: @
Alt Gr + 3: £
Alt Gr + 4: $
Alt Gr + 5: €
Alt Gr + 6:
Alt Gr + 7: {
Alt Gr + 8: [
Alt Gr + 9: ]
Alt Gr + 0: }

I run AVG and found nothing. I now run Spy Bot … and it seems to take some time!

What you describe with voice type looks like assistive technology. Maybe a setting for the blind ?

Yes. It was my initial thought!
Where are these settings!?

There is a Windows Update at some 1,5 GB waiting to be downloaded…
However, I need to think about the download since I use mobile broadband.
I’ll do the download tomorrow, at other location.

If you are familiar with the registry, here is a page which shows how to change the default setting (Option 1):

RegEdit All Indicators Off

If there is a value of 2 or 6 in the registry, then change it to 0. You may need to reboot the computer for it to take effect.

[quote=149125:@Jakob Krabbe]Yes. It was my initial thought!
Where are these settings!?

There is a Windows Update at some 1,5 GB waiting to be downloaded…
However, I need to think about the download since I use mobile broadband.
I’ll do the download tomorrow, at other location.[/quote]

Before doing the update, or manipulating the register, there is one last thing you may want to try : go into the Recovery Control Panel, and use Restore to put your system back as it was before the keyboard started acting up. It will wipe out any installs you may have done since, but it should replace the keyboard in its normal state.

Then if this was to happen again, try to remember what you did or what software you installed that created the problem, not to fall in this trap again.

Allright…
I will try.

I edited the registry, but after reboot, the problem remain. Even without reboot, the problem remain!
What a challange!!

I’m considering to reinstall Windows…
Maybe even to Factory settings, as there are nothing important on this computer.

However, it will take some time and I will choose when to do it.
Now is not a good moment!

Thank you very much for all advice!! I’m impressed!!

For “@” are you looking for something different than Shift-2? Nvm, looking at the keyboard picture again, the @ is off to the side, not above the 2. I assume you’ve tried Alt-2 and Fn-2?

Seems something related to MS Narrator. Check this, disable or reassign keys.
http://www.7tutorials.com/how-use-narrator-windows-81-desktop-pcs

Jakob,

here in my windows 8.1 Laptop, I have Alt Gr-0 (no shift): @ to get it everywhere and Alt-0 (no shift) to get it inside Xojo (special case ?).

This may be the case too for you ?

PS: I wrote about that some days ago, but no one noticed that…

Thank you for the input!
I think, I can live with it… or re-install Windows and return to factory settings.
For this, I need to download again, Firefox, Thunderbird, Xojo, Dreamweaver, Open Office…
I mean, I need to be mentally prepared for this!! :slight_smile:

The issue is not at all related to Xojo.

In Sweden, the @-sign has been Alt Gr + 2 since… 20-25 some years back in time… I don’t know, but it’s not a new feature, not related to Samsung.

I tried earlier to fiddle with MS Narrator, as the link described above, but it’s not at all compatible with the Swedish operating system and it’s not even possible to … turn on, check settings or to fiddle at all!

It was my original thought, that it was some how related…


To solve the problem, I will simply need to save the chars in a text file, @£$€{[]} and use copy/paste when needed.
It’s fine for now. It will be less complicated to all alternatives that seem to be.

Or! Maybe I just make a little editor, the text creator, with buttons for these special chars, as I use instead! When writing e-mail address to Facebook and such…!

It will be the fast and reliable solution!! Ha!

“No shit, it’s a hit!”
That will do it! :slight_smile:
CopyPaste 1.0 Final Release!