No Save As to XML / VCP any more in 2015r4?

Despite having a Desktop Mac license (verified via the IDE’s menu command), I cannot use Save As to save to any other format than the binary format.

I thought this binary-only format was a restriction for the free version only?

Single Desktop unfortunately does not have version control save formats :frowning:


If I win that $1.4 billion jackpot I’ll buy you a desktop license for your 64bit work with your zip tools.

Me too?

Single desktop was basically the replacement for the old Personal license which also doesn’t not have the ability to save as XML or VCP

Tony Riviere

This is a great draw back for someone like me using Xojo at home. I want to be able to take a printed copy of the code to the nearest armchair and use it to plan my next modification over a cup of tea. Why this daft and unattractive limitation?

Each version has features not available in lesser versions… These are the incentives that XOJO uses to increase their revenue.

So I deem it neither “Daft” nor “unattractive”… Plus this does NOT keep you from PRINTING the code…

And as far as I am aware the ability to print is neither more or less enhanced regardless of which level of XOJO you license…

It does limit you from using some 3rd party documentation tools, such as XJPrint , but not from using the printing capability in-built to XOJO.

Sorry to be grumpy. I want to be able to print with all the coloured text that one sees in the IDE. Also, if I look in the About Xojo/EULA it does say that to print in Text or XML formats a license key ( I haven’t read the whole EULA document) is required, but not that it is not included in the single desktop version. I am retired and an amateur at this business but have enjoyed the mental exercise of using Xojo.

Open your project
In the navigator make sure NOTHING is selected
Select File > Print

Thanks for that. If I do that then it is only black and white printing unfortunately. I will make do with that.

Change your preferences to print in color

Thank you. That works perfectly. I should have thought of that!