No DEB for 2015r4?

Hi team,

Is there going to be a dpkg for Debian / Ubuntu? Installing from the tgz results in an odd crash when you exit relating to the package not being installed properly on Ubuntu 14 and 15 distros.

Maybe they’re still trying to resolve this:

feedback://showreport?report_id=41414 Installer for Ubuntu / Debian Linux - Error - The Package is of Bad Quality

Have to love that lintian bug which identifies that package as being of “bad quality” :stuck_out_tongue:

Perhaps there is an adjustment that can be made to the Xojo i386 Debian Package so lintian accepts it. Wish I understood lintian enough to help. The bug doesn’t impact all Debian Packages with Xojo apps because ours work for i386, amd64 and armhf.

I looked into this just before the break, and there’s a bug in one of the Perl scripts that is part of lintian which causes it to incorrectly return an error when closing the package after it has been examined. Correcting the bug does allow our package to install, but we can’t very well suggest that users log in as root and change a system level script. I’ve filed a bug report with the maintainers of the script and hopefully it will be resolved in an update soon.

[quote=238837:@Tim Jones]Hi team,

Is there going to be a dpkg for Debian / Ubuntu? Installing from the tgz results in an odd crash when you exit relating to the package not being installed properly on Ubuntu 14 and 15 distros.[/quote]
I would like to know more about this “odd crash” as the tgz is our fallback. I can’t say that I’ve seen such an error on any of my machines. Is there a specific error if you install it from the command line?

Thanks for taking the time to explain.

It simply has the system info and one error - “the package is not installed properly”. I only see this if I kick the IDE off from the command line as root, not from a link in the application menu.

BTW - you guys should still include the Xojo xpm/png for manual inclusion in the various menu systems.

We’d probably use an XPM since we still support old distros that dont use PNG’s

Hm supposed to be there. Could you file a bug report?