No Build gear icon

I am trying to add a copy files build step for a windows desktop project.
There is not a build gear under Windows in the build settings. There is under Linux and OSX.
I get “Can’t copy files in a prebuild step” error when trying to build the project.
What am I missing?

Just drag the Build Step on the “Windows” entry in the Build Settings. This will create the “build” entry with the gear icon and add the build step.

I inserted the Copy Files build step, it was added to the contents section, I then added a SQLite file and dragged copy files onto Windows under Build Settings.

CopyFiles1 shows-up under Windows but no Gear icon/Build.

I used find to search Build, I show:
BuildAutomation.Linus.Build.Name and BuildAutomation.OS X.Build.Name

nothing for Windows.

I’ve not seen what you are describing. Do you have a screen shot? Does it do it with a blank project?

I just started a new desktop project and the Build Gear is there???

There IS a bug that allows a person to actually remove the BUILD step from a project
Was just reported & fixed
The only work around I know of is to save & edit the build steps in VCP format by hand

Send me your project and I can fix it

Thanks for the offer! I had been making backups along the way. I went back to my last backup, it had a build step.

I just had to rebuild a little of my work. Amazing how much faster it can be done the second time.

I’m having the same issue with a project - the Build Gear Icon does not appear under the OS X or Linux Build Settings section. I’m about to dig in further to see what file(s) I need to fix.

@Norman Palardy - What’s the fix?

  1. Save as VCP - or XML but the XML is MUCH harder to edit
  2. edit the BuildAutomation item
  3. for the ones where it’s missing insert
    Begin BuildProjectStep Build
  1. save and reopen your project

I basically did the same thing by creating a new project and added the exact same build steps and then diff’d the ‘Build Automation.xojo_code’ files in and applied the diff to the original (busted) project file.

I don’t believe that I deleted the Build Gear step previously, but it’s possible. If not I suspect there was a bug in a previous version of the IDE.

I’m not aware that the IDE has ever dropped it on its own