NilObjectException… vanished

Earlier today (two hours and a power onff /on later), the NilObjectException I started to get disappears.

Before quitting Xojo, I realized that I misplaced two MenuHandler (in the App Class instead on the main window), so I Copy / Paste them, one at a time, and I delete them from App. I run the project (in the IDE) and saw the NilObjectException (in a Picture at display time, not before). Then I quit Xojo, finish the browsing session and come home / eat / and see the Nil does not exists anymore / now.

Developement / OS versions:

Xojo 2015r1 El Capitan .6

Running applications (now):

Firefox, Custom Xojo created multimedia application, Xojo 2015r1, Preview, TextEdit, Gimp.


Internet on (different ISP), External HS (Standard HD, Toshiba, 1 TB, USB 3.0)

Why bother ?
That is months since this kind of things happens to me. To avoid that amap (As Much As Possible), usually, at power on, when I want to develop a project, I only fire Xojo. Most of the time, I clear the Xojo cache before running Xojo. I already saw strange things, but this (happy) one happens at a good time for me: I recall very well what happens. Also, usually, the trouble happens in the reverse order: all is well (no, not Shakespeare) before, and after a reboot, something wentwrong at reboot time, later. I just recall: at some time in the past, I stopped the use of an external HD because I experienced trouble when one was connected. I also tried to always disconnect WiFi.

Can you imagine the time wasted with this king of behavior ?

Did you get this kind of trouble(s) ?

Edit: Added GIMP to the list of fired (but I quit it before running Xojo).