New SOAPMethod doesn't work.

I am trying to set up a Soap Method on my server. As this is my first attempt with Xojo, I created a mico-app that would let me connect to a SOAP server on my machine and then communicate with the application. I can’t get past the initialization stage. Here is my code snippet.

MsgBox “button clicked”
Dim sm As SOAPMethod
MsgBox “sm dimensioned”
sm = New SOAPMethod(“http://LarryWorkLaptop/u2/u2Tools/v3/u2SOAP/LARRYSOAP\PROG.wsdl”)
MsgBox “New Soad Method Dimensioned and initialized”

Every time I run this the program hangs on the sm = New SOAPMethod line. I get a debug error that looks like this.

Error Number: 69
Line: 1
Message: Unknown Encoding

What do I have to do to get past this. The WSDL file is created by my SOAP Server so I know it to be correct.

Any help would be appreciated.



I’d suggest you look at the example - Examples->Communication->Internet->JSON Example.

Based on the error, it sounds like the encoding for the incoming string is Nil. You probably need to call DefineEncoding so Xojo knows what it is.

Greg, thanks, I will give it a try and let you know if it worked.


Can you post a solution please? I am running into the same issue with a UTF-8 encoded WSDL on a server that is working great with my iOS app (objective-c). I have never used the SOAPMethod class before tonight, so I may have some basic misunderstanding of it’s use.