New Framework - Naming Conventions?

I’m still at 2013r3, although my subscription runs until 2021 :slight_smile: so all the new stuff didn’t get much attention by me… I’ve hoped the new framework will group names better to easier find what we need in long method/property lists.
I.e.:

(Edited: “Text”, instead of “String”…):

*** Text Functions:
Text.Base64encode
Text.Base64decode
If there are a lot of convert functions it might make sense to do
Text.Convert.Base64toText
Text.Convert.Base64fromText
Text.Convert.HTMLtoRTF
Text.Convert.HTMLfromRTF

Text.Search (or SearchPositionGet, for my taste)
Text.SearchReplace
Text.SearchReplaceAll
Text.GetLeft
Text.GetRight
Text.GetMid
Text.Encoding. …
Text.CaseUpper
Text.CaseLower
Text.CaseTitle

*** Control Properties, i.e:
PositionLeft (instead of Left)
PositionTop (instead of Top)

*** Listbox, i.e:
RowHeightDefault (instead of DefaultRowHeight)

I know there’s not that one right naming scheme. It depends on the contents of a class, and something that was yesterday good is in a few cases tomorrow less good, if the class get’s a lot of new content…
I always try to have the “thing/subthing” in front and the “action” at the end, which is mostly the best way to keep things well organized. It’s actually following the dot notation logic, mostly. In my projects, my names are also quite descriptive. :wink:

Yoda understands me well.

isn’t that “Understand me well, Yoda does”