Need a recipe!

I’m trying to get a CentOS 7 server to run web apps. It all seemed so easy… Install, upload, set some permissions… Nope!

Here is what I have done:

  • Net install using CentOS-7-x86_64-NetInstall-1511.iso
  • Select Basic Web Server in the install

At this point the machine is running but NO web server! How convenient!
Connect and:
[root@ptax2 ~]# firewall-cmd --permanent --add-service=http
success
[root@ptax2 ~]# firewall-cmd --reload
success
[root@ptax2 html]# vi index.html
[root@ptax2 html]# systemctl restart httpd
[root@ptax2 html]# vi phpinfo.php
[root@ptax2 html]# systemctl enable httpd
Created symlink from /etc/systemd/system/multi-user.target.wants/httpd.service to /usr/lib/systemd/system/httpd.service.

Now my very rudimentary web page shows up and PHP works.

Upload all the files in the test app, CGIDeploy64bit.zip_Linux 64 bit_XojoTest to /var/www/cgi-bin using WinSCP
Also using WinSCP set everything from /var/www down to 775. Set config.cfg to 666.
Now when I go to http://ptax2.xxxxx.com/cgi-bin/xojotest.cgi I get the following:
“Cannot write to config at path /var/www/cgi-bin/config.cfg. Permission denied”

So I search for that and find this post:
https://forum.xojo.com/20190-webapp-doesn-t-start/0
and so I try:
[root@ptax2 html]# setenforce 0
[root@ptax2 html]# systemctl disable selinux
Now the error is:
“Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at root@localhost to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.”

Which sounds worse to me so I reverted back to the previous snapshot. I’d really like to get this working. It would be nice to have a current recipe for both the major flavors (RH & Debian) as a sticky at the top of this forum! So much has changed over the last few years finding accurate info is difficult.

Thanks!

This says the http user(www or whatever it could be) does not have permission to write to your apps config file. Fix that and it should work :slight_smile:

I always do standalone apps though. Way easier to deploy.

It’s simply a bug in an older version of Xojo which did not set the proper permissions for config.cfg. Just set all permissions for that file and you are good to go.

Just out of curiosity, is this server out on the internet and have you ever managed a public facing server before?

Thanks for the replies!

Albin - I can set the permissions to 777 and still get the same results. I have a feeling the error message is at least one step removed from the actual problem. From my understanding of how this works standalone isn’t a good option since there will quite a few simultaneous users and around 25 versions of the app running on the same server. Wouldn’t I run into port confusion?

Michel - App was compiled in 2015R3. The Xojo supplied CGIDeploy64bit.zip_Linux 64 bit test app won’t run either.

Greg - Yes it is on the Internet. I have run various public facing web/mail servers for at least 15 years. Most have been either Sun Cobalt or their successors so not very complex but I do know my way around RH based distros. Ubuntu based takes me a bit longer. While I understand not getting into all the gory details isn’t the best idea simply providing a current recipe for both the major flavors (RH & Debian) to run a Xojo supplied test app as a sticky at the top of this forum would be very useful.

All - The Xojo cloud works great! Last night I deployed 10 apps and loaded their not tiny databases in about 3 hours from order to done and it works GREAT! While that is fine and good there are several reasons I’d really like to know how to deploy these on other servers.

Whoops, make that 2016R3! Current version!

Strange, strange, strange.

I regularly upload 2016R3 cgi builds to 1701’s ServerWarp which is under CentOS 7.1.1503, and have never observed the config.cfg issue.

The fact that you set to 777 and still get the same message is quite odd.

Where are you building the app ? I do that on Mac so permissions are already set. On PC, you may need to set permissions manually for all files.

Just making sure (I had 6 cobalts at one point in my own company), don’t want users to go off and think that managing a server is a set it and forget it kind of thing.

Greg - No problem! Sun Cobalt is alive and well as BlueOnyx. Well supported and it would sure be nice if Xojo web apps ran on it. (actually I’m not sure it won’t, given my general lack of success I’m not sure of much right now)