Nearly there but so much faff.. XCode version now!

I can compile my iOS app in Xojo 2017 and run on simulator and my new iPad.
I’ve jumped through hoops I didn’t know existed on the Apple developer site, compiled ‘for the App Store’ and tried to upload today.
Not having it.
I get a message to say that I have used Xcode 9 to build instead of Xcode 11?

[quote]ERROR ITMS-90725: “SDK Version Issue. This app was built with the iOS ‘9.3’ SDK. All iOS apps submitted to the App Store must be built with the iOS ‘11.0’ SDK or later, included in Xcode [9.0] or later. Please update Xcode and rebuild your app.”
[/quote]
Since I used Xojo to build, Im not sure what to do next.

I have a current licence but Xojo 2018 wont run or build…

You absolutely need to use Xojo 2018 to release on the App Store, it doesn’t seem to be an Xcode problem

What version of macOS / Xcode do you have?

I have an Xcode 8 which has within it a reference to SDK 10.3
I have an Xcode 9.2 which shows Base SDK as 11.2 but doesnt seem to have an ‘update now’ button where I can see one.

Xojo 2017 opens the project and runs and builds
Xojo 2018 1.1 opens the project but will not run or build.
iOS licence expires 11 Aug 2019
Xojo 2018 will not run any of the example projects either.

Jeff, I think the message is about the iOS SDK and not Xcode.

My guess is you have Xcode 8 and 9 on your system and is picking up Xcode 8 to build. From what I read you need Xojo 2018 and Xcode 9.

Edit: there are some posts here in the forum on how to change Xcode 8 to Xcode 9 to build projects.

deleted Xcode 8
ran Xcode 9 - it will compile an app and display in simulator
Xojo 2018 still doesnt like it

tried to update Xcode 9 in App store… I am on OSX 10.12 (dont want High Sierra) , so it says I need to download the most recent which is compatible.
Will I need to upgrade to HS too?

This feels like I will end up building an app that 4% of iPad users will actually be able to run, if I ever get it working.

From what the error say: must be built with the iOS ‘11.0’ SDK or later, included in Xcode [9.0] or later I don’t think High Sierra is needed (at this point).

There are other posts with people that had trouble making Xcode 9 work if they had Xcode 8, but if I remember correctly most of them were able to make it work.

You may want to try a VM with clean OS install and Xcode. That will help you be ready when Apple requires High Sierra, or if you want to have a clean environment to build iOS apps.

Shirt.
Deleting Xcode 8 has broken Xojo 2017 now too.
This has been a nightmare.

So far, 3 days to write a nicely put together app ,
plus 14 days of pain and suffering over Apple’s certificates, security, libraries, SDK, simulators…

Jeff,

There are some commingling issues taking place on your system. I battled similar issues for at least a week. You need the Xcode 9.4 and 2018 r1 at a minimum now to get Apple to accept your ipa. Here’s the rub. You need a license for 2018r1 to build for the App store. 2017 r3 will build and run but not build for the App store. To get this done you will need to upgrade Xojo. Make sure that Xcode Preferences>Locations Command Line Tools is set to the current Xcode. I had to remove Xcode 8.0 entirely. The ipa and build will be for arm64 and you can’t modify the plist to run under armv7. The App store will reject all builds unless they are arm64. You can also partition your Mac and install Xcode 9, Xojo 2018r1 or 2. You will need to allocate at least 50GB to the partition. You can also do the inverse and build an armv7 App by installing Xcode 8.xx and Xojo 2016r4 keeping in mind that the build will only be good for running on your own devices. If you go the partition route also keep in mind that none of you certificates will be in the keychain and must be installed. It’s a very circumlocutinous process. I just made up that word.

Ha.
Not the ones I already had. 3 iPads in the bin, brand new iPad Pro bought for this and still not much further forward.

Im installing new Xcode now - thansk for the tips above, which I will work through

Edit: Installed new Xcode ‘The plugin or one of its requisite plugins may be missing or damaged and may need to be re-installed’
So I cannot get to anywhere to set the command line tools

Xojo 2018 has a run button, but it doesnt build.

Jeff,

Keep us posted.

My App Boat Minder is on the App store now but I wanted a copy for my own use on my iPad 2 which will only run armv7 so that’s why I set up a partition for the older versions of Xojo and Xcode rather than buying a new iPad. Took a couple of days of fooling around but a lot cheaper.

Presumably you are getting an error building in 2018? Make sure you have the proper xcode tools selected and your developer account selected in Xojo. At this point testing with 2017 versions doesn’t make sense - you can get false positives about your app working when it doesn’t under iOS 11.

What about all the folks running iOS10 and iOS9?
Has Apple just shafted them all?

Or put another way, if I had done this last year, there were several million more people who could potentially use my app, whereas now its a relatively tiny proportion of the iPad user base…?

Please stop making wild statements with no data.


https://developer.apple.com/support/app-store/

[quote=401705:@Jeff Tullin]What about all the folks running iOS10 and iOS9?
Has Apple just shafted them all?[/quote]
Most people are on iOS 11 at this point, 81% as of June.
http://www.idownloadblog.com/2018/06/05/ios-11-adoption-rate-81-percent/

Apple wants its users to update, and if you want your app available for sale you have to target the latest version. Like it or hate it that’s the requirement.

This just means that the app needs to be built with the newest SDK (and for that you need an up-to-date Xojo version).
With Xcode you can still build apps supporting iOS 9 (maybe even older ones). However, Xojo seems to have limited support for iOS 10 and newer in their 2018 releases.
In other words: With Xojo, you can currently upload an app supporting iOS 10 and newer.

Apple hasn’t. Xojo has it limited a bit. But to be honest - it’s quite a pain having to link to the newest SDK and support old versions. Some things always break - and you’d need to test an a device with every iOS version if you really intend to support these iOS versions.

Thank you.
That certainly wasn’t clear from the need for iOS 11 SDK

So so so close.

Wiped Xcode and emptied trash
Installed Xcode 9… failed to run
Wiped and emptied trash
Installed again and it starts. Woohoo!

Xojo 2018 runs the app, and it works in the simulator.
It builds for device testing.
But although I had a profile, building for App Store fails
with

[quote]'NSLocalizedRecoverySuggestion=Xcode couldn’t find any iOS App Store provisioning profiles matching
‘com.sitename.appname’.
Automatic signing is disabled and unable to generate a profile.[/quote]
Ive generated a distribution profile again and downloaded it. Not sure what else I can try.
So close

Downloading the provisioning profile does… Nothing.

Open xcode, go to preferences > account, then click the download manual profiles button.

Restart Xojo and build.

You can also try opening a dummy test project in Xcode and check Automatic signing then do a “repair” for the profile. Stay in Xcode until your dummy project recognizes your team in automatic signing.