NAS drive access

Customer reports that they cannot save files on an NAS drive, where Notepad and other apps can:

Disabling security on the file hosting W10 computer worked.
Also on my NAS device, when I used a mapped folder that had security turned off, it worked.
So long as authentication isn’t required it seems to work. I assume that however your software accesses the windows file system, it is not co-operating with sending credentials to the remote computer. Or it could just be that it is but is using some new security features that I don’t have configured correctly that other programs aren’t using yet. <<[/quote]

I dont recall ever having to do anything security related in my code when getting a folderitem and saving to it.
Is there some setting I need to know about ?

Do you just write the file or do you use xojo iswritable etc to check before you write?

I do check iswritable first.
In fact, it may be that it is reporting read-only incorrectly

try dim par as folderitem par = f.Parent if par.IsWriteable = false then msgbox par.Name + " is read-only. Try another location." exit sub end if catch end try

Ive seen this before :

[quote]Both .IsWriteable and .IsReadable can fail when trying to access a file on a NAS device. This is with Xojo 2019R1.

Here are two native paths to the same file that fail on both of these functions:

\\\Lighting\Control\Lightwright Issue\SD0049-LX-Anna Lighting Plan v2019.lw6

\\\Lighting\Control\Lightwright Issue\SD0049-LX-Anna Lighting Plan v2019.lw6

There are Feedback reports on both of these, #998 (.IsWriteable) and #55731 (.IsReadable). If nothing else, Xojo should update the documentation to say that they are unreliable and should be deprecated.

There are many cases where the right thing to do is just try to write the file and deal with the failures because isReadable and IsWriteable aren’t, and in some cases cant, be made reliable

Yes, don’t bother checking, just write it and catch any issues on the write.