My web server is not accessible in Mojave

Hi all. As I recently had to move to Mojave and, as a consequence, to Xojo 2018r3, I need to fix a number of issues with my Xojo projects.

In one of them, I implement a very basic webserver on port 8888. All was working fine in RS2012r2.1/Sierra but now the server socket receives nothing with Xojo2018r3/Mojave, even though lsof shows that a socket is actually up and listening on the right port.

Any thought?

Maybe something else is using that port?

Is the firewall blocking incoming requests?

@Greg O’Lone — Unfortunately no (I have tried to find any process using that port with lsof, with no avail. Also, I changed the port number to a random number with no success).

As a note, I cannot connect either through localhost:8888, (IPv4) or [::1]:8888 (IPv6)

Have you tried if you can scan for the ports with the network utility?

Did you check your Firewall?

System Preferences->Security and Privacy->Firewall

Click the lock to authenticate and click Firewall Options.

Make sure your app is in the list and has “Allow Incoming Connections” on the right side.

If the app is not signed, macos may not even ask if you want to allow connections. Mojave is a lot more paranoid than previous OS’s