Multiline helptag not working

I’m trying to set up a multiline helptag for a weblabel from a variable in code. If I type in a mutliline helptag from the IDE, it works fine. But when I try to do it from code, the program crashes. I’ve tried using CHR(13) and also chr(10) for a line break. I’ve also tried using the Endofline.unix and endofline.windows as suggested in the webcontrol.helptag help file. They all crash the program. I’ve also tried using " " for a line break, which is also suggested in the help. That does not crash the program but it doesn’t create line breaks; it just puts " " where line breaks should be. I would appreciate any direction on how to get this to work.

Try
.

Michel, I appreciate the suggestions, but that just shows up as “line1
line2”. Do you know if there might be a way to do this with ExecuteJavascript?

Feedback ?

The crashes you see with your attempts are due to the fact that you feed control characters to JavaScript.
is the documented HTML way to create a line break.

I modified the content of the help tag, actually the title in HTML, and inserting
indeed does not cut the line. I don’t think it supports multiline at all.
https://www.w3schools.com/jsref/dom_obj_title.asp

You best bet is to create a custom control maybe based on WebCanvas.

While I don’t remember if this is enabled for tooltips (and it’s 6am and I’m not near my computer) have you tried wrapping the contents of the tag in tags and put the in the middle?

Which browser do you use? It works here except for Chromium (
 doesn’t work).

First, create a html file, add this code, and try in your browser.

<div title="first&#13;second&#10;third">
    Content
</div>

This code works well on Firefox, Chrome, even IE6.

Xojo version:

Label1.HelpTag = "first&#13;second&#10;third"

You are right, Asis, works perfectly on Mac as well in the HelpTag field of a WebControl.

that sounds like <https://xojo.com/issue/47820> but it should be fixed in 2017r3. For the support of multi-line helptags in general, see <https://xojo.com/issue/26496>

You can add css to styling the helptag including multiline and depends on your css code, this custom helptag may be supported on all major browsers.

Maybe I’m doing something wrong, but “&#13” doesn’t work, “&#10” doesn’t work, “
” doesn’t work. I’ve tried this all with and without adding and none of them work. They all just add the text to the label. I’ve tried this on Windows in Chrome, Firefox, Edge, and Opera and none of the above work with any of the browsers. It works fine if I add a multiline helptag from Inspector in the IDE, so clearly the generated code is different when you enter it in the IDE than when you get it from a variable, but I don’t know how I could compare those.

Did you tested this code?

[quote=367885:@Asis Patisahusiwa]
First, create a html file, add this code, and try in your browser.

[code]

Content
[/code][/quote]
Content

Works as expected in my browser, showing a multiline helptag. It doesn’t work for me as a helptag in xojo.

[quote=367935:@Kevin Clark]


Content

Works as expected in my browser, showing a multiline helptag. It doesn’t work for me as a helptag in xojo.[/quote]
Then it’s Xojo issue.

Tested on Windows 7 (Xojo 2016R4.1 using firefox, Opera, Chrome) and Windows XP (Xojo 2015R2.4 using Firefox, Chrome) works fine.

You forgot the terminating semi colon. Every character counts :

Michel, I forgot the semi-colon in my message, but I had it in my program. Whatever I programmatically put in the helptag is displayed exactly as is.

Ok, how about this. Why don’t you create a simple sample project that shows the problem and share a link no so others can see your actual code.

Well. I tried here with the simplest of test projects in 2016R3 : one weblabel with in help

one&#13;two

I get two lines in Chrome, Safari and Firefox.

Unless you are using an ancient version of Xojo which may have filtered HTML out, I don’t see a simpler project.

Michel, I tried what you tried and created a project with exactly one weblabel. Putting one two in as the helptag either through the inspector or as a variable in code properly gives a two-line helptag. Then I copied that exact string into my original program were it had not been working. It still does not work. So, there’s some setting or something else that I’m doing that’s preventing it from working. I’ll just have to keep investigating.

Which version of Xojo are you using ?