Moved Rest-API to Xojo Cloud - Don't work anymore

Hi Guys,
i made an API based on the REST-API Tool “Luna” with XOJO.
I tested it successfully on my local machine, different Linux-Server and it works fine.

Yesterday I moved the API the the Xojo Cloud, but nothing happens.
All my PAW Requests didn’t work anymore.

I think, it could it be because the URL of the web app includes now (on Xojo Cloud) the name of the app.

Do you have an idea how to fix it?

Best Regards

What does the url you’re using to access the site look like? I have not worked with Luna, but if it is using handlespecialurl then your url to access it needs to be

See note about XojoCloud:
Xojo Docs HandleSpecialURL

Hi Steve,

the old url was

For a model (e.g. the server info) the url is

but now on the xojocloud I have to add the app name (http://xx.xx.xx.xx/appname/v1/info) and this doesn’t work.

I believe you would need to make it

If its just using Handleurl rather than HandleSpecialUrl then I think it would be

As Steve notes, you have to include the index.cgi as part of the path on Xojo Cloud. So your URL would look like one of the following depending on whether you’re using HandleSpecialURL or HandleURL:


More info:

Hi Paul and Steve,

Problem solved.
Now the api works.

@Steve: Sorry I didn’t understand your suggestion the first time :wink:

Thanks a lot.