MouseEnter and MouseDown

[quote=74844:@Paulo Vargas]Hello,
I have a similar problem because if I leave the ‘Global Floating Window’ in COCOA when I come back I can not focus on a textfield that needs focus, only if I click on, not for me ran “Me.Show” on Mouse Enter, any suggestions ?[/quote]
Do you really need a GLOBAL floating window? Or is a normal floating window enough?

Hello Markus Winter,

        Yes I need my window is on top of the other for a number of reasons, but I've tested it on floating window and document window and also had the same problem of losing focus of my window in various situations.

on the global floating window

Sub MouseEnter() me.TextField1.SetFocus End Sub
works fine here with Xojo 2013 R3.3 (last one to run on my Snow Leo system)

Hmmm, works from inside the app just fine, however from outside the app clicking on the global floating window does NOT activate it or the app. Seems like a bug to me. Not sure if it has been fixed and can’t check in the feedback app as Xojo does not support the feedback app on my system.

I don’t have the time to check this, but would it be possible to have a workaround by catching any mousemoved event (on a Mac, you could handle this via Cocoa.NSEvents.MouseMoved using for example MacOSLIb) and check if the mouse is over the app window – and if yes, activate it if it is not yet active?

ME.SHOW solved it for me

Oh yes, that’s easy. Thanks a lot!

(It doesn’t solve my problem with a floating window not floating anymore when a child is attached to it, but the window is responsive. And of course that’s another problem, so how about checking this one solved?)

Yes for me is a ‘Bug’ because I can not turn on when ever I click on the desktop or in another open program.

Oh, you’re right. I had it running in the foreground always.

Yes, and this complicates because the MouseEnter, MouseExit, etc. commands do not work … if I was not in the foreground, tried to make a feedback but do not know why I’m not getting because this function is not released in the new update, at least for me!