More Mac OS X FullScreen shenanigans...

I have noticed a Mac OS fullscreen problem which I think is another bug:

When a main application window is made “FullScreen” and a floating window is “hidden” (set Visible = False), setting it’s “Visible” property to True again will not re-display the floating window. This worked correctly in 2013r2. An additional problem having to do with toolbars being forced to Visible in FullScreen mode is documented here:

feedback://showreport?report_id=30899

I’ve included a link to a FullScreenTest application that can be used as a cross-platform framework for an application with FullScreen capability (not as simple as one may think), but also summarizes the FullScreen bugs that I have found. The example works perfectly in Xojo 2013r2, but displays incorrect behavior in 2013r3 and up, regardless of the “FullScreenButton” setting (the new Mac 10.7+ fullscreen paradigm).

Full Screen Test App

I realize that FullScreen windows are a rarity in Xojo, but I have a commercial application that can not be compiled with anything later than 2013r2 because of these bugs. I’d like to make use of the new FullScreen functionality in Mac OS X.

Has anyone else come across this?

Cheers.

-bill k

Bill, if you show that floating window from your main window, does it still disappear?

Greg,

I am showing the floating window (winMiniController) from the main window:

winMiniController.ShowWithin(Self)

in the cvsPreview.MouseDown event I have:

winMiniController.Visible = (Not winMiniController.Visible)

The line above gets executed every time the user clicks in the canvas, but the floating window never re-appears (though it does get hidden the first time). This seems to be a bug, even in the simplest case (a document window and a global floating window, with the visibility toggling code in the main window’s mouse down event).

Try using Show and Hide instead of toggling Visible.

Thanks Greg. Evoking the Show/Hide methods based on the value of the Visible property seemed to do the trick. This still doesn’t address the other problems that I am having with FullScreen on Mac OS, but at least I can compile with the latest Xojo rev. now.

Cheers.